Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently did a fresh Windows XP install on a Dell Latitude D510 (It's not mine, im only "the tech guy"). All fine, it just wouldn't use its wireless card. And by that I mean nothing is happening, like it's not recognised, or something.

  • Checked BIOS, it's enabled.
  • Been looking for a wifi switch on the sides for hours, found none.
  • Discovered Fn+F2, did nothing.
  • Googled Dell latitude D510 wifi driver, found 3 possible drivers, installed. Nothing.
  • Found out about Quickset, installed. Now Fn+F2 shows, wether it's on or off (the hardware LED is still dark though)
  • Device manager sees some mystical Ethernet driver and Network driver (with a yellow question mark) under Other devices
  • Under Network adapters, there's this: 1394 Network Adapter

Any help is appreciated.

share|improve this question
    
Seems like a driver problem or a MAC address problem. Try to change the MAC address of the wireless card manually on Device Manager. The MAC address of any computer that you know is accessing the Internet should work. –  Doktoro Reichard Aug 23 '13 at 14:47
    
What do you mean it "wouldn't use it's wireless card?" What behavior are you seeing vs. what are you expecting? Your last bullet makes it sound as if the card isn't recognized; what's shown under the Network Adapters node? Did you try the official Dell drivers? Do you know for sure that the card is what Dell shipped, and not something someone else added? –  ernie Aug 23 '13 at 14:53
    
@DoktoroReichard The system doesn't even recognise the card being there, I hardly believe I could change its address. –  Sakknekedro Aug 23 '13 at 14:54
    
@ernie I will update the question –  Sakknekedro Aug 23 '13 at 14:54
    
Have you tried any of the drivers mentioned in the Dell driver page –  Doktoro Reichard Aug 23 '13 at 14:54

1 Answer 1

up vote 3 down vote accepted

Couple of issues/suggested steps:

  1. 1394 is another name for FireWire
  2. The lack of anything else under network adapters suggests you're missing drivers
  3. Did you install the chipset drivers from Dell's driver page? Generally, that's the first thing you should install on a fresh Windows install as that'll contain the drivers for the motherboard, and some of it's integrated components.
  4. Sounds like you'll need to install the Broadcom drivers to get the Ethernet working
  5. Instead of installing 3 different (wireless?) drivers, identify the wireless card itself. You could do this by opening the system, and checking the card, or you can try looking up the laptop using it's service code on Dell's support website, which may contain a shipping manifest. You mention installing the recommended network drivers - I see four recommended, with one being for Dell wireless, another being for Dell Bluetooth, and two for the Broadcom Ethernet NIC. If you want wireless, install the right wireless driver.
  6. Finally, after identifying the actual wireless card, then install the correct drivers and go from there.
share|improve this answer
    
Well, turns out it wasn't under "Modem/communication" but "Network", an 'urgent' driver. Shame on me... –  Sakknekedro Aug 23 '13 at 15:25
    
Works now, thank you all for your time! –  Sakknekedro Aug 23 '13 at 15:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.