Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I upgraded Ubuntu 9.04 to Ubuntu 9.10. After a restart this is all I get:

usplash: setting mode 1280x1024 failed-40b0-8f4d-c4afe4ee4001
usplash: Setting mode 1152x865 failed
usplash: Using mode 1024x768

Ubuntu 9.10 nate-desktop-ubuntu tty1

nate:desktop-ubuntu login:

Update: After running sudo nano /etc/usplash.conf, changing the resolution to 800x600, running sudo update-initramfs -u, and finally restarting, this is all I get:

Boot from (hd0,5) ext    1f60f2b0-6a61-40b0-8f4d-c4afe4ee4001
Ubuntu 9.10 nate-desktop-ubuntu tty1

nate-desktop-ubuntu login:

I can login but all I get is this terminal. How can I get to my desktop, files, icons, or apps?

Update 2: Someone suggested it not a usplash problem but an NVidia problem. Any help?

share|improve this question
FYI: usplash has been supplanted by xsplash – ephemient Nov 7 '09 at 20:33
Ubuntu Karmic runs both usplash and xsplash, to leave no stage of the boot process unprettified. usplash may well be dropped in future though. – bobince Nov 9 '09 at 19:52
Looks like it's all being dropped in favor of Plymouth for 11.04 – ephemient Dec 14 '09 at 19:30

This seems to be a common error particularly for nVidia users at 1440x900: bug 67826.

Try changing the resolution in usplash.conf (sudo nano /etc/usplash.conf then sudo update-initramfs -u) to something simpler, eg. 1024x768.

Or just apt-get remove usplash completely; it's not exactly an essential part of Ubuntu. (The ubuntu-desktop metapackage relies on it, but there's little harm in removing that.) Since xsplash comes up so quickly now for me in 9.10 I dropped usplash and don't really see any disadvantage. It'll probably be gone in 10.04 anyway.

share|improve this answer
The error is gone but Ubuntu still boots up as a terminal, how do I access my desktop? – nateify Nov 7 '09 at 20:32
hmm. What happens when you run startx from the command line? Any more useful error messages? – bobince Nov 9 '09 at 19:51

I had a problem with my Nvidia driver. I reinstalled the driver and everything worked correctly after a reboot.

share|improve this answer
up vote 0 down vote accepted

A fresh install of Ubuntu did the trick.

share|improve this answer

Problem: Flashing Black screen post upgrade. All restricted drivers were disabled and removed.

In my case the live distribution CD worked fine. A full wipe and reload would also have worked, but I didn't want to reconfigure and download my "Special drivers" for my lightscribe drive and Genius tablet.

Upgraded from 9.04 to 9.10. After the upgrade, the system rebooted with no graphics and flashing screen. Tried on two different PC with same issues. Finally found a solution that worked without having to wipe and reload the entire hard drive. I don't know if this will work for others with different video cards, but it worked for me on both my PCs.

  1. Boot Ubuntu in recovery mode
  2. Change to the x11 directory. Delete the xorg.conf.

    cd /etc/X11
    sudo rm xorg.conf

    Also remove all xorg.conf files.

  3. Reboot PC after all xorg.conf are removed and let Ubuntu restart. Re-enable Restricted Drivers.

  4. Go to terminal. Type

    sudo nvidia-settings

    Select the correct video settings for your display.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.