Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am not able to update my PHP in centos 6.

I have centos base, epel and rpmforge repos.

yum update php
Error: Package: php-tidy-5.3.3-14.el6_3.x86_64 (@updates)
Requires: php-common = 5.3.3-14.el6_3
Removing: php-common-5.3.3-14.el6_3.x86_64 (@updates)
php-common = 5.3.3-14.el6_3
Updated By: php-common-5.3.3-23.el6_4.x86_64 (updates)
php-common = 5.3.3-23.el6_4
Available: php-common-5.3.3-22.el6.x86_64 (base)
php-common = 5.3.3-22.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
.. install failed!

I believe php-tidy has been excluded due to repo priority. How do it fix it?

EDIT
epel.repo has "priority = 10" Could it be a reason?

yum update -d3

gives list of excluded updates. --> php-tidy-5.3.3-22.el6.x86_64 from base excluded (priority)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You may wish to disable extra repositories while trying to upgrade packages.

There are some tricks that you can try when you have multiple repositories that contain different versions of the same package. CentOS has this wiki article with some tips and tricks for specifying a certain repository to use.

Using this information, running

yum --disablerepo "*" --enablerepo "updates" update php

should clear up this issue.

share|improve this answer
    
"No Packages marked for Update." I guess it is because PHP updates are in base. –  Mahesh Aug 24 '13 at 9:30
    
--> php-tidy-5.3.3-22.el6.x86_64 from base excluded (priority) - This is causing the problem. I m not able to fix it –  Mahesh Aug 24 '13 at 9:47
    
Have you tried disabling the repositories as suggested and enabling the repository you're trying to install php from? You most likely have conflicting priorities. Can you grep -ri priority /etc/yum.* and update your question with this output? –  andrew Aug 24 '13 at 10:12
    
I tried the command in your answer. Tried both epel and rpmforge both says "No package marked for update." grep for priority says epel.repo has priority = 10 –  Mahesh Aug 24 '13 at 10:15
    
Most likely. Give yum --disablerepo "*" --enablerepo "base updates" update php a shot. –  andrew Aug 24 '13 at 10:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.