Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a HP laptop with decent specs:

  • Processor: AMD A8
  • Memory: 4 GB
  • Graphics: 1.5 GB (1x 512 MB integrated, 1x 1 GB dedicated; configured in CrossFireX)
  • Operating System: Windows 8 x64

I have installed Ubuntu 13.04 on a VirtualBox virtual machine and have allocated 1 GB of RAM and 1 processor core to it.

The problem is the VM runs painfully slow. When I allocate similar configuration to another VM running Windows 7, it works just fine, even with Aero turned on.

Another problem is when I switch to any VM with mouse integration on, and I switch back to the host OS, the trackpad swipe gestures stops working, even after switching off the VM(s).

share|improve this question
1  
assigned at least 2 cores of your quad core CPU. Do you have the guest tools installed? –  magicandre1981 Aug 24 '13 at 5:48
    
Okay I will try allocating two cores. Do I need to change PAE settings as well? –  Ammy6Teen Aug 24 '13 at 5:58

1 Answer 1

up vote 1 down vote accepted

I had the exact same problem with Ubuntu and my experience was that it was mostly Unity making things dreadfully slow. Change from Unity to Gnome, LXDE or some other lightweight window manager and I believe things will become better instantly.

Also, my experience is that any VM should be given at least 2 cores if possible as that also will improve performance. 36 MB or more RAM from the graphics card should be allocated to the virtual machine as this allows full integration between the host and the VMs screen.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.