Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am getting the following error when creating an external switch on Hyper-V:

Hyper-V Error

I am running Windows 8.1 x64.

My switch settings are as follows:

External Switch Settings

Event viewer gives me the following errors in Applications and Services Logs -> Microsoft -> Windows -> Hyper-V-VMMS in the order of logging:

1) Timed out trying to acquire network configuration lock, current owner = 'Binding Engine Task Queue Handler'.

2) Switch delete failed, switch = 'C8486DBE-CFB6-4355-99E3-19CD37C6D606': Operation times out (0x80041069).

3) Failed while removing virtual Ethernet switch.

share|improve this question
    
did you solve this problem? I'm getting the same error and I have the same wireless network card :( –  andrecarlucci Mar 25 at 14:57
    
@andrecarlucci Sorry, no solution yet. I stopped using Hyper-V in the end. It would be nice to learn why this happened though... –  rhughes Jun 5 at 8:19

4 Answers 4

1)Did you try launching Hyper-V Manager with Administrative rigths? .

2) Try closing the properties Windows because your network adapter might be running another instance which is making some conflicts

share|improve this answer
    
None of this helped in my case. I was surprised that I was able to create Internal Virtual Switch worked after I clicked Stop Service in Actions followed by Start Service –  mlt Jun 1 at 1:45
    
I did try those options, thanks, but to no avail. –  rhughes Jun 5 at 8:19

Do you already have a switch bound to that NIC? If you don't see it in the GUI use the nvspbind.exe tool at an elevated prompt as in this Microsoft Article.

Creating V-switches within the hyper-V environment fails

It will show you what virtual switches are attached to the NIC and allow you to unbind them.

share|improve this answer

I think that is a problem with hyper-visors and bridging a wireless NIC, i have tried and never succeeded even on VMWare or VirtualBox. So no bridge on a wireless NIC on a Virtual Machine.

The solution is to create a loop-back interface on Windows and bridge that one with the VM, and then share the wireless connection with other interfaces on PC.

share|improve this answer

If you can't cretae external switch on Hyper-V.

First you need to create a new internal virtual switch.In order to do that, kindly follow the below steps.

Open the Hyper-V Manager and select your server.

In your Hyper-V Manager window, Top of the screen to the left side the second option is "ACTION". Click on ACTION.

In the ACTION tab now select "NEW VIRTUAL NETWORK" and "INTERNAL" and click on "OK".

In machine, Go to

CONTROL PANEL ==> NETWORK AND SHARING CENTER ==> MANAGE NETWORK CONNECTIONS.

Now locate the active Wireless network adapter and do RIGHT click on the "PROPERTIES"

Click on "SHARING" tab and check the box which has the option "Allow other network users to connect through this computer's Internet connection".

Now go to Hyper-V manager and do "RIGHT" on the respective server and click on

SETTINGS ==> NETWORK ADAPTER ==> in virtual switch drop down choose the EXTERNAL VLAN (NAME YOU GIVEN) and enable the Virtual LAN identification.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.