Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed several different versions of Git on Windows all with the same failure. I get an error "libssh2.dll is not installed on this computer...".

I looked around the installation files, and, Windows is right, it's not there. I've tried installing the ssh2.dll binaries (the only place I could find them is in a php distribution), putting them in the system directories and everything.

Does anyone know the source of / or a solution to the problem?

share|improve this question

2 Answers 2

That bug was fixed in 2011.

I would recommend, as an installation process, to simply unzip a portable version of msysgit.

PortableGit-1.8.3-preview20130601.7z 

There won't be an issue then.

share|improve this answer
    
This is a good answer I guess. People like it. I cannot resolve this problem on two different computers. Maybe I am handicapped. –  user1167442 Mar 13 at 23:41
up vote 1 down vote accepted

I finally resolved this. I can't say exactly what the source of the problem all along has been - in other words, why it hasn't worked with various git installations, etc. Though I expect the problem was the same; it doesn't make sense that I kept installing different broken Git packages.

At any rate, what solved it is this:

I had downloaded the libssh2.dll binaries from the libssh2.org website, but the file that came with it was libssh2-1.dll, which went undetected by git. It didn't occur to me rename it, but that might've worked.

However, what did work was downloading the Cgminer binaries, which - as I somehow discovered - happen to contain libssh2.dll.

I then copied libssh2.dll into ..\mysisgit\bin, and git has worked perfectly since. God knows why it wasn't there; especially since this is the version of mysisgit that is packaged with cmder (thus I assume it is a recent mysisgit version).

This has driven me stupid. Notice the date of my original post.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.