Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just compiled OpenWrt (attitude_adjustment) without firewall

When enter ifconfig no br-lan appear, moreover eth1 static ip doesn't show :

root@OpenWrt:/# ifconfig
eth0      Link encap:Ethernet  HWaddr 2D:72:20:2D:76:20
          inet addr:192.168.0.191  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2530 (2.4 KiB)  TX bytes:1946 (1.9 KiB)
          Interrupt:16

eth1      Link encap:Ethernet  HWaddr 2D:72:20:2D:76:21
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:15

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:48 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3936 (3.8 KiB)  TX bytes:3936 (3.8 KiB)

My /etc/config/network config :

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

I don't know where to search for. Perhaps bad menuconfig when building?

share|improve this question

migrated from serverfault.com Aug 24 '13 at 17:03

This question came from our site for system and network administrators.

    
The static IP would not appear on eth1. It would appear on br-lan instead. (You don't configure IPs on the individual interfaces connected to a bridge; ifconfig will let you do it but it won't work). So the lack of br-lan is definitely the main problem. Try to gather error messages. E.g. does anything show if you restart the network manually (/etc/init.d/network restart)? Or if that doesn't show anything, manually creating a bridge with brctl? One obvious possibility is that you don't have bridge support in your kernel (CONFIG_BRIDGE). – sourcejedi Oct 6 '13 at 10:59

You can think of eth1 as one physical interface on you router which is connected (hardwired to the switch), which includes all your Ethernet LAN ports (4 in most home routers).

Now br-lan is logical interface between eth1 and that switch. It is configured by default in OpenWRT (which oddly isn't in your case). You can create this virtual interface manually by LuCI or CLI. Here is the guide to do it in CLI: https://wiki.openwrt.org/doc/networking/network.interfaces Or you can use LuCI which is simpler. Select interface as bridge and select eth0 (your WAN port) and eth1.

share|improve this answer

You must log in to answer this question.