Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just got myself an iPhone 3GS, but I can't connect it to my router at home

Under network settings I can see the name of my wireless, I'm trying to connect using the passwords I have but it fails to connect. I'm sat in the same room as the router so signal should not be an issue

The router I have is a Netgear DG834 GT

I'm using WEP, I've tried both the passphrase and also the 26key password, neither work.

I'm using an access list, so I've tried adding the iPhone mac address to that, still didn't work. I've also tried disabling the access list and still doesn't accept it

My router firmware version is : V1.01.28

share|improve this question
up vote 1 down vote accepted

When it comes to diagnosing a problem like this, I would start by dropping MAC security as it is possible that you entered the MAC address incorrectly.

Next, if you still cannot connect, double check the passphrase for 1il, B8 and 0o type errors.

If you still cannot connect, try changing the passphrase to something like test.

Also, it is worth checking to make sure you are using the correct security mechanism (TKIP v AES)

share|improve this answer
@Wil, Thanks for the update. I've double checked the passphrase and the 26digit key, both are typed correctly. If I disable security on my router, it works fine. Just can't get it to accept the WEP key once I switch security back on. Any ideas? – user155695 Oct 31 '09 at 17:58
Is there any specific reason for using WEP? I would try changing to WPA or even better, WPA2... lastly, I know you won't like it, but it is worth trying to change your WEP key to something simple like test, then try to connect again - just to rule it out (not saying you are wrong, but it could be something else preventing it - when it comes to security, you just want to get down to the very basics in order to diagnose!) – William Hilsum Oct 31 '09 at 18:13
@Wil, it works if I set WEP to 64bit (I was previously on 128bit). I will try to configure it for WPA. I think we can close this call and I'll raise another if WPA gives me problems! Many thanks and brownie points incoming! – user155695 Oct 31 '09 at 18:44

Just incase you didn't figure it out. I had the same problem. I wrote exactly what i saw on the wireless security page when setting up the modem. The whole number doesn't fit on the bar given, so make sure you have all of them, one number was hiding. It worked for me. Try it.

share|improve this answer

According to Apple's Choosing a password for networks that use Wired Equivalent Privacy (WEP):

Choosing and using a WEP password can be a challenge, because WEP is an older security protocol that was developed before members of the Wi-Fi Alliance had agreed on a uniform way to treat passwords. The result is that a WEP password may not work for all computers in a multiplatform environment.


  • For a 40 bit WEP network, always choose a 5-character password.

  • For a 128 bit WEP network, always choose a 13-character password.


Products that allow plain language (ASCII) password entry may not force the network administrator to create 5- or 13-character passwords that would result in the required 40 (5*8) and 104 (13*8) bit-length passwords. Instead, they use a "hashing" routine to convert an odd-length password to the correct bit length. The multiplatform issue arises when the hashing results of products from two different manufacturers don't match each other. The resulting "network equivalent passwords," which are always given in hexadecimal format, are different.

(Still, use WPA2 when possible!)

share|improve this answer
Just wanted to agree... we used to have a WEP access point... and visitors with Macs would always have problems connecting. Try disabling WEP (temporarily.. just to see if it solves your problem) and/or upgrading to WPA/WPA2. – Brett Oct 31 '09 at 20:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .