Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I cannot access http://download.blender.org from within my home network. I have Linksys router (WRT54GL) switching into 2 PCs with ethernet cable and also wireless enabled (which I use in my Android mobile)

So far, I tried:

  • Access it with Firefox from my home PC, got "Connection reset"
  • Access it with Chrome from my home PC, got "Web page is not accessible"
  • Pinged it from home PC, got "Request timeout"
  • Access it from other PC in my home (in the same network), got the same results
  • Access it from my Android phone connected via wireless to my home network, the same result
  • Confirmed at the ISP that they're not blocking the site (SOA#1: it works on their part)
  • Accessed it from http://isup.me - got "it's just you, the website is up"
  • Accessed it via annonymous proxy - and this worked, I've got a valid response and could access website
  • Wipe out all settings at router (reset to factory defaults) and then try again, got the same results

I am pretty much out of ideas... what can I do to resolve the problem?

share|improve this question

1 Answer 1

This is quite possibly related to the packet MTU size (default on most routers is 1496 bytes). I have found quite often that this causes the Connection Reset error on sites. If you can increase it to 1500, that might help, otherwise look for an updated firmware for the WRT54GL.

If you're into drastic measures and the updated firmware doesn't fix it (and Linksys UI doesn't support adjusting the MTU) you could try a custom firmware like Tomato or DD-WRT.

share|improve this answer
    
My MTU is set to 1500, and it does not help. I will attempt to connect directly to ISP's router with completely skip of my Linksys router to see if that help (my friend recommend checking that out), but it requires a bit of digging into cables, so I will do it later on –  PiotrK Sep 15 '13 at 13:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.