Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I disable the beep when I reboot Debian 7? I have gone into /etc/inputrc and made the console not beep and have muted Beep in alsamixer but it still happens. I have seen reference to blacklisting the pcspeaker module but am not sure I want to kill that all together, I just want to kill this particular alert.

Edit So, it seems this might have something to do with the networking. I was also fixing it so that the wired connection was not trying to connect at boot and, therefore, delaying the boot while DHCP timed out. Fixing that seems to have made the beep go away. Even though the beep is gone, I would still love to understand the why behind all this. I posted a pastebin link in a comment below of what was happening during reboot while the beep was still happening.

share|improve this question
    
/etc/inputrc is the wrong source to look at. Use strace to identify the evil beeper. It reminds me of an old keyboard in ca. 1987, it made a short beep with every keystroke. You could disable with some command, but it came back after every reboot. One day later I opened the keyboard and cut the speaker's cables. The sound of silence. –  ott-- Aug 25 '13 at 20:16
    
So, I tried the strace thing... couldn't find the answer there but here is what it gave in case someone else can. http://pastebin.com/77vhYtNT –  GeneBean Aug 26 '13 at 3:23
    
There it is in line 317: the write \7\r\n. Can you look at the source if it can be turned off? –  ott-- Aug 26 '13 at 7:30
    
@ott-- So, I looked at the line you referenced but I am not understanding... do you mind elaborating or pointing me to something that explains what you are saying? Thanks! –  GeneBean Aug 27 '13 at 18:50
    
I meant you should look into reboot's source code to see if it the beep could be avoided. –  ott-- Aug 27 '13 at 19:10

2 Answers 2

The following worked on my LMDE (Linux Mint Debian). Edit the file /etc/modprobe.d/alsa-base.conf and add this line:

options snd_hda_intel beep_mode=0

Here are some of the other things I tried in case that one does not cut it:

  1. Blacklist pcspkr, this is not a big deal by the way, you can still hear movies etc it is just the onboard speaker that produces the beep that is disabled:

    echo "blacklist pcspkr" | sudo tee -a /etc/modprobe.d/blacklist
    

    sudo modprobe -r pcspkr

  2. Add this to /etc/gdm3/greeter.gconf-defaults:

    gconftool-2 --type bool --set /desktop/gnome/sound/event_sounds false
    
  3. Depending on what is causing the beep (is it reboot, or login or what?) this might work, it disables the terminal warning bell:

     xset b off
    
share|improve this answer
    
I had already tried the xset one... no luck. Thank you for the info though. –  GeneBean Aug 26 '13 at 3:24

I had the same annoying beep and found a patch on the debian bug report logs. So I decided to have a look at it. The patch will remove a \007 from a file called dowall.c which will be include in the shutdown binary.

I read the debian handbook page for rebuilding a package from source and built the sysvinit package for me with the patch applied.

This package contains a lot of important stuff and I was to scared to install the package. (It is my first package I built for debian) :) That's why I only extracted the shutdown binary file from the package and moved it to /sbin/shutdown.

Afterwards the annoying beep was gone...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.