Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having an odd problem. My keys won't repeat when held down. its fine to type and I can double touch just fine. however I can't hold and repeat. This problem has prevented movement in games that require holding down the keys to move forward. I have checked and filter keys is off and so is sticky keys. I have cleaned up my registry several time and this hasn't solved the problem. I have also restored old versions of windows 7 even going back as have as 4 years ago the problem is still there. Can anyone help?

share|improve this question
1  
Whay keyboard are you using? Have you checked repeat speed on Control Panel >> Keyboard? – Doktoro Reichard Aug 25 '13 at 23:10
2  
Can you test a different keyboard? Are there any programs running (especially in the background) that could be intercepting hotkeys? Do you know when this behavior started/how long it’s been happening (conversely, did it ever work correctly)? – Synetech Aug 25 '13 at 23:51
    
First try a different keyboard. – Mokubai Aug 26 '13 at 8:07

Went to "Ease of Access Center" Windows7 (32-bit).

There isn't any box to 'untick' at "Turn on Filter Keys" but there is an off/on option. Switched it to the 'off' position and hey presto, I can get 'repeats' on my keyboard by holding down any specific key. Thanks. Nick

share|improve this answer

This just happened to me and it's because my cat was lying on the keyboard I think.

If you hold down the right shift button for 8 seconds in Windows, Filter Keys turns on which limits the number of keystrokes so you can press one key only once in a 1-2 second period. This limits your ability to type any words with double letters in them, limits your scrolling with the arrow keys on websites, limits using the delete button, etc.

In Windows 7, the option to turn this off is under "Ease of Access Center" settings and then-->"Make the keyboard easier to use", then uncheck the box for "Turn on Filter Keys" in the control panel. It's not listed under Keyboard or Mouse settings.

I hope this helps someone else.

share|improve this answer
    
OP has explicitly stated that filter keys are off. – gronostaj Jul 3 '15 at 22:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .