Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a couple of network security cameras that use PoE and I would like to use them outdoors. The problem is that I do not have network ports anywhere outside, so the solution I came up with was to use a couple of Buffalo N450 access points -- one is connected to my home network via a hardwired connection and is set as an AP, while the other is in Client Bridge mode and connects to the other via wireless. Both the AP and Client Bridge are set up with non-conflicting static IP addresses.

The network cameras are connected to the ports on the Client Bridge N450 through a pair of PoE injectors.

Things generally work -- there is an application one can install on a PC, and when I run this app, I can see all of the cameras. The problem is that when I use the iPhone app, I cannot see them.

I figure the issue is that the cameras just don't have access to external servers. I have tried to debug this problem as best as I can, and this is where I'm at:

  • The AP can ping my cable modem and external servers like google
  • The Client Bridge can ping the AP, but cannot ping external servers
  • The AP is set up as a DHCP forwarder
  • I have confirmed that DHCP is working by connecting to the AP's wireless network via my iPhone
  • I have confirmed that DNS should be working because when I am connected to the AP's wireless network, I can run the SpeedTest app and it is able to reach the test servers.
  • However, when I use the Administration->Commands tool to ping www.google.com, it doesn't give me any response. Normally, when ping works the resulting page shows the ping response times, but in this case it doesn't return anything, or I get PING www.google.com (74.125.28.106): 56 data bytes ping: sendto: Network is unreachable. EDIT -- my guess is that even though a client on the wireless network can get outside (of course, the AP can do it), the Client Bridge must have its WAN settings incorrectly set, or there is something on the AP side preventing the bridge from getting out.
  • In addition, when I connect my iPhone to the AP's wireless network and then run the security application, it still can't see the cameras!

These seem like conflicting results -- how can the Client Bridge not be able to ping google, while a client connected to its wireless network get everywhere on the internet just fine? Can anyone suggest further tests to run?

Here's a diagram that I drew up of the current network setup:

enter image description here

This is how my wan/lan are set up on the AP:

enter image description here

And my Client Bridge:

enter image description here

I'm more than happy to post other settings if they would help with the debugging process!

EDIT -- I'm beginning to think that using ping via the "Run Commands" utility is not a reliable way to test the connectivity. While I am pretty certain that I can't ping external servers, the ability (without changing any settings) to ping internal devices like the cable modem (and even the AP!) is flaky. I know the connection is okay because my desktop is pinging the Client Bridge constantly, and it is consistently working.

share|improve this question
    
You are using the 192.168.0.x subnet. Even though every network device now days should support classless subnets, I've seen devices (namely wireless bridges) not able to connect. It would be worth a try to see if the issue persists after moving all devices to 192.168.1.x subnet. –  spuder Aug 26 '13 at 4:50
    
@spuder thanks, I'm going to mess with a few more settings and will then give a different subnet a try. –  Dave Aug 26 '13 at 5:22
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.