Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've searched for a solution for this online and on superuser, but nothing seems to work. Every time Java is being used on a site I am on, a security warning appears with the text "Do you want to run this application?". There is no option to stop this box appearing again. I have verification disabled in my Java Advanced settings

I have no idea what to do to fix this. It's really annoying and I don't want it to continuously appear every time I am on a site which I have already granted access to use Java in the past.

  • OS: Windows 7 64-bit
  • Browser: Google Chrome
  • Java Version: JRE8, JDK1.8.0


the message box which appears.

Additionally, I am using Java 8 because it fixes a problem which is only presented to me on my computer when I am using Java 7; when launching applications which connect to the internet (such as Minecraft Launcher), it causes computer-wide lag for around 20 seconds before finally loading. It was not always like this, and it just decided to start doing this one day randomly. No solutions to this problem can be found online, other than one suggestion to install Java 8 (which fixes the problem but causes some java plugins to fail, like JTablet). I have tried uninstalling and reinstalling Java 7 several times, both 32bit and 64bit, with no luck.

share|improve this question
2  
JR8 is in such a state that Oracle has said that work on it will be delayed until JRE7 is stable. This particular setting is handled by the Java Control Panel applet. –  Ramhound Aug 26 '13 at 13:08
    
Java really acts weirdly on my computer... For example, I installed Java 8 again last night and the plugin JTablet, so that I could get tablet pressure working on java apps in browsers. However this did not work. Today, I repeated the steps and it suddenly works now... So this isn't much of a problem; the first problem I have however is still there, the warning continues to appear. –  Dragonphase Aug 26 '13 at 13:36
    
Did you adjust the security settings in the applet? –  Ramhound Aug 26 '13 at 13:44
    
The security settings are on the minimum possible setting. –  Dragonphase Aug 26 '13 at 13:50
    
That tells me then you will be unable to get rid of the security prompt. the prompt is handled by java's security settings. –  Ramhound Aug 26 '13 at 13:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.