Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded my internet speed to 90 mbs but when I run a speedtest on my computer, it never gets over 50 mbs. I've had the ISP company over here a few times, they've tested everything and have shown that the internet speed is in fact 90 mbs and sometimes even 100 mbs but their thought is that my ethernet and wireless ports on my HP can't accept or run at those faster speeds. Also, just to confirm my speed, I connected the ethernet to a dell laptop and sure enough, it's running at the 90 and 100 mbs.

I've tried playing around with the settings on the network adapter Realtek PCIe FE Family Controller, adjusting to auto, 100/Full Duplex, 100/Half Duplex, 10/full, 10/half but my internet speed never changes. So, is there a setting or some other update for this issue?

share|improve this question

1 Answer 1

unfortunately i believe the problem is with the realtek controller. i connected an external usb wireless dongle into my laptop and the speed instantly matched up with the ethernet cable. i've searched the internet but have not found any fix. next time i won't buy anything with realtek on it!

share|improve this answer
    
Realtek is fine you just have a 10/100/1000 port –  Ramhound Aug 30 '13 at 21:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.