Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently bought an ASUS laptop. I already have a desktop which connects to my router via ethernet. The laptop connects the internet through the router via Wi-Fi. Both machines have Windows 7 x64 Ultimate. Below is the detailed description of my problem:


I cannot connect to my laptop from my desktop or vice versa for transferring files.

What prerequisite steps I have performed

  • Set up static IP addresses on both machines ( and with common default gateway ( under TCP/IP IPv4 properties of the network adapters
  • Disabled Windows Firewall for Home Networks on both machines
  • Set the network adapter as part of the Home Network
  • Turned on file and printer sharing in the Network and Sharing Center and disabled password protection as well.
  • Ensured that the services --> HomeGroup Listener and Server are running (although no idea if this is required or not)

What I am able to do/see

  • I am able to create a Homegroup using either machines in which case the said machine shows as being part of the group.
  • I am able to see the machine in the Network list
  • I am able to ping the machines successfully via IP as well as host name

What I am not able to do

  • Connect to the machine. I get a "Network path not found" error.
  • When I try to join the homegroup created by the other, I get prompted for the password, I enter it, it attempts to connect and after a brief period it gives an error.

Other details

  • Desktop has SP1 installed, laptop does not.
  • None of the machines' antivirus (AVAST FREE VERSION) has the firewall component installed
  • I have already tried the steps as mentioned in this post
share|improve this question
Do you have sharing turned on in Network and Sharing center? –  Ashtray Aug 27 '13 at 8:26
@Alex : Yes I have sharing turned on as also password protection is disabled. Will update my post as well. –  Vrushank Aug 27 '13 at 9:21

2 Answers 2

perhaps you should consider looking at your both computer's name. computers with same name will never meet a network and rather sometimes either one of the machine will not be able to access the internet, sometimes both. homegroup is not necessary to connect two PCs. Try to share your documents folder on both of your PCs on your network and see if the problem was still the same. if its not what your looking for, a graphical illustration can help a lot.

change both of your PCs IP address and DNS settings to obtain address automatically and turn off the firewall. Then look for your computer name on the network folder, if you cannot see either of the PCs, just type their name in the address bar and you should be able to access both of them

share|improve this answer

I had the same problem, but i solved it by creating share password for users on both clients.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.