Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a laptop with a Intel HD4000 and a nVidia Quadro K2000M. I just reinstalled Archlinux on my laptop on this morning, so it’s a fresh install.

I graphics drivers that way:

yaourt -S xf86-video-intel intel-dri bumblebee nvidia

I enabled bumblebeed, I even installed bbswitch, I’m stuck to that error:

skypers@ark ~ % optirun glxspheres
[  815.104395] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed     to initialize the NVIDIA GPU at PCI:1:0:0.  Please

[  815.104447] [ERROR]Aborting because fallback start is disabled.

Here’s some info:

skypers@ark ~ % dmesg | tail         
[  662.121696] NVRM: os_pci_init_handle: invalid context!
[  662.121702] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[  662.121705] NVRM: os_pci_init_handle: invalid context!
[  662.121706] NVRM: os_pci_init_handle: invalid context!
[  662.153026] NVRM: RmInitAdapter failed! (0x25:0x28:1157)
[  662.153035] NVRM: rm_init_adapter(0) failed
[  814.696877] bbswitch: enabling discrete graphics
[ 1366.370707] bbswitch: enabling discrete graphics
[ 1366.370728] nvidia 0000:01:00.0: power state changed by ACPI to D0
[ 1366.380940] nvidia 0000:01:00.0: Refused to change power state, currently in D3

The Xorg.8 log file. Any idea ?

share|improve this question
    
I have the same problem, anyone that has a solution? –  Tirithen Mar 17 at 17:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.