Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to install opera 12.16 on ubuntu 12.10 (gtk 3.6.0) & fedora 19 (gtk 3.8.2).

  1. When I start Opera at both systems as "strace opera" , I have the same error: http://codetidy.com/6507/

  2. If I start Opera on fedora without "strace" nothing happens in console and opera isnt running.

  3. If I start Opera on ubuntu without "strace", I see this error:

    ** (opera:5012): CRITICAL **: os_bar_hide: assertion `OS_IS_BAR (bar)' failed
    
       (opera:5012): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed
    
       ** (opera:5012): CRITICAL **: os_bar_set_parent: assertion `OS_IS_BAR (bar)' failed
    
       ** (opera:5012): CRITICAL **: os_bar_hide: assertion `OS_IS_BAR (bar)' failed
    
       (opera:5012): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed
    
       ** (opera:5012): CRITICAL **: os_bar_set_parent: assertion `OS_IS_BAR (bar)' failed
    

But on opensuse 12.3 (gtk 3.6.4) opera works fine.

Anybody who fix same errors for opera help me please!

share|improve this question
    
What Desktop Environment are you using? –  terdon Aug 27 '13 at 14:36
    
(Ubuntu) Did you apt-get these from the Ubuntu Universe/Multiverse? –  Colyn1337 Aug 27 '13 at 14:46
    
teron, on fedora use xfce. On ubuntu - Unity. –  user2716324 Aug 27 '13 at 15:02
    
Colyn1337, No, i download opera .deb from opera.com. –  user2716324 Aug 27 '13 at 15:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.