Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Linux Mint 15. I'm using the keyboard shortcut "Super_L" to open the Mint menu of the Mate desktop.

Now I want to use for example the shortcut "Super_L+1" to open a terminal window. I went to Menu->Control Center->Keyboard Shortcuts and assigned the proper key combination to "Open a terminal window". It shows up as "Mod4+1".

Having done that, pressing "Super_L+1" has this strange behavior: 1st press: opens mint menu 2nd press: opens terminal 3rd press: opens mint menu ...

The shortcut works every other key press which is very annoying. Is there a way to reliably use such shortcuts?

I only found this thread which mentions the same issue but doesn't give a working solution http://forums.linuxmint.com/viewtopic.php?f=55&t=31550

share|improve this question
up vote 3 down vote accepted

I don't think you can do that. What I've done is mapped the Menu key (the one that opens context menus) to open the Mint menu. I don't use that key anyways, and you can always use Shift + F10 to get the same effect.

Then I was able to map key shortcuts with the Windows (Super) key without a problem.

share|improve this answer
1  
I haven't found any better answer either so I'll accept yours. It's too bad though there's no other way! – bernie Nov 30 '13 at 4:55

I did almost the same as Bojan suggested. I have Linux Mint 17 Mate.

However, the Mint Menu hotkey is not listed in MATE's Keyboard Shortcuts dialog.

If you right click on the Mint Menu applet, and select Preferences, then on the first tab, you can select another hotkey to replace <Super_L>, or if you just want to remove that hotkey at all, you can press backspace.

share|improve this answer
    
nice, that works! – Martin Pfeffer Mar 28 at 1:32

This problem was annoying me as well. I never use the Super key for the start menu, anyway, and opening a terminal is much more important to me. I solved the annoyance by opening the following file:

/usr/share/mint-configuration-xfce/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

It contains the following line:

<property name="Super_L" type="string" value="xfce4-popup-whiskermenu"/>

I changed it as follows:

<property name="&lt;Super&gt;m" type="string" value="xfce4-popup-whiskermenu"/>

And added another line underneath:

<property name="&lt;Super&gt;t" type="string" value="xfce4-terminal"/>

(Don't forget to restart the operating system after making the changes.)

Now I can still open the start menu if I want to via Super+M, but the Super key does not interfere with Super+T anymore. (If you don't need a shortcut for the start menu at all, just remove the entire line.)

share|improve this answer
    
Thanks for the tip, though it's strange to have to go root just to remove a keyboard shortcut. It was not needed on Linux mint 17.2 XFCE edition, I found that the Super_L shortcut does appear in the keyboard shortcut list, can be removed and has the intended effect, permanently. – Stéphane Gourichon Nov 4 '15 at 17:59

Same issue here. I finally solved it. The small tool ksuperkey, which has been developed for KDE, works perfect with other desktops.

In Xfce, I bound whiskermenu to "alt-f1" and put ksuperkey into autostart. Do the same for the application launcher you're using in Mate. The super key will behave as one would expect.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.