Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After I tried installing OpenSUSE 12.3 with Windows 7 (which was already installed) I got this message:

Multiple active partitions No bootable device -- insert boot disk...

I'm a bit confused with grub2.

I have tried to fixed with a live version of OpenSUSE and with PartedMagic and no success so far.

Windows 7 had 4 partitions so I deleted the one's with the drivers (recovery partition) and create an extended partitions with swap and two ext4 for Linux.

Here are the details of my hard disk:

Disk /dev/sda: 500.1 GB, 500107862016 bytes

255 heads, 63 sectors/track, 60801 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0xe6394783

Device           Boot        Start         End      Blocks   Id  System

/dev/sda1                        1          26      203776   42  SFS

Partition 1 does not end on cylinder boundary.

/dev/sda2                       26       33139   265980928   42  SFS

/dev/sda3                    58636       60789    17293312   42  SFS

/dev/sda4                    33140       58635   204796620    5  Extended

/dev/sda5                    33140       33445     2457913+  82  Linux swap

/dev/sda6            ?      264486      299763   283359510   92  Unknown

What do I need to do to set up the partitions correctly and be able to boot both systems?

share|improve this question
1  
IMO Your question is pretty unclear -- right now it's just an explanation of a symptom you're seeing and how you broke it. What exactly are you asking us to help you with? Which partitions are set to Active? what happens when you put the partitioning back the way it was when it worked last? Why not just backup data, blow all away and start over? –  techie007 Aug 27 '13 at 19:00
    
All I want is to ask for help, sorry if it is not very clear. if I start my laptop and I am getting this message, I would like to find a way to solve this problem, after spending a few days. After running fdisk with partedMagic, that is what I found. Just starting now to get familiar with linux. No way to recovery from windows, no cd or dvd with windows 7 –  user248986 Aug 27 '13 at 19:06
    
no way to start recovery manager in windows and no cd or dvd with windows7 –  user248986 Aug 27 '13 at 19:17
    
I have a problem because if I run partedMagic, I see the whole disk unallocated. However, this is not happen with live openSuse or when I try to install once again opensuse 12.3 what shows all the partitions. I think, it means, that windows is still there, I hope so. but not idea how I can put this back. I will try to put the partitioning back, –  user248986 Aug 27 '13 at 19:26
    
I prefer not to put partitioning back as I am not sure if windows will be eliminated if there are no linux partitions to go with opensuse. No way to do anything with partedMagic. –  user248986 Aug 27 '13 at 19:57
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.