Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just purchased an iWork '09 box. After the installation, I tried to open Keynote but instead a popup appears asking me to enter a serial number. But the serial number is nowhere to be found on the box or on the DVD ... But I'm sure the box version of iWork '09 doesn't even require a serial number. So what's going on??

One thing to note is that I did install the trial version of iWork '09 before installing the full version. So I also tried removing iWork '09 trial completely before installing the full version ... no luck.

Does anyone have a clue of what I might be doing wrong?

share|improve this question

migrated from stackoverflow.com Oct 31 '09 at 20:48

This question came from our site for professional and enthusiast programmers.

1  
Consider accepting an answer if one of them helped you. –  Daniel Beck Jan 2 '12 at 23:14

4 Answers 4

sudo rm -rf /Library/Application\ Support/iWork\ \'09/

and install from DVD once again. That did it for me.

share|improve this answer
    
worked perfectly. I too had installed the trial first while I waited for the boxed copy from the local apple retailer. –  curtismchale Oct 29 '10 at 1:21

I had trouble installing iWorks on my new MacBook Pro, sudo worked for me too.

I first had installed a trial version of iWork, and when I installed from my DVD I was asked for a serial number. After removing iWork the installation from DVD worked. I used the following command:

sudo rm -rf /Library/Application\ Support/iWork\ \'09/
share|improve this answer

Apple changed their minds about serial numbers and it has caused some problems.

From this Apple discussion thread:

Remove all these files:

<bootVolume>:Applications: iWork '08
<bootVolume>:library:com.apple.iWork08.Installer.plist
<bootVolume>:library:com.apple.iWork08.plist
<bootVolume>:Users:<userAccount>:Library:Preferences:com.apple.iWork.Keynote.plist
<bootVolume>:Users:<userAccount>:Library:Preferences:com.apple.iWork.Numbers.plist
<bootVolume>:Users:<userAccount>:Library:Preferences:com.apple.iWork.Pages.plist

and then reinstall from the disk. (Tip from Yvan's post in this thread).

Similarly remove any of the iWork '09 in any of those locations.

share|improve this answer
    
Thanks for your reply! Unfortunately this doesn't work for me :( –  Tom van Zummeren Oct 31 '09 at 23:35
    

I had this exact same problem. I tried erasing all my files that had anything to do with iWork and reinstalled it, but it kept asking me for a serial number. So I went online to apple.com and downloaded the latest updates for iWork, and now it stopped asking for any serial number and everything is working fine.

share|improve this answer

protected by random Sep 26 '10 at 3:43

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.