Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just upgraded to Ubuntu 9.10 (network upgrade using the update manager, from 9.04 which had different graphics related problems) and when I try to boot into it all I get a small Ubuntu logo, flickering text and then the tty1 command line with a logon prompt.

startx gives following error:

Fatal server error: no screens found

I traced down a tutorial that said I needed the latest graphics drivers (Gigabyte ATI Radeon 4650 HD installed with 9.10 catalyst drivers) so I did using the 'sh' command and a USB stick (I have a working Windows partition) and it installed fine but did not fix the problem.

Edit: Thanks to UK and Arjan below I was able to understand the full error message of start x:

Parse error on lone 2 of /etc/X11/xorg.conf
'nameserver' is not a valid keyword in this section
Fatal server error: no screens found

This has nothing to do with a graphical error (sorry if I misled anyone) but the xorg.conf file has 3 lines in it and lines 2-3 have an entry 'nameserver'. Using the nano command I commented out (using a # before the entries) the nameservers and can now boot Ubuntu.

Thanks to everyone for their help.

share|improve this question
Do you get an error when trying to run startx ? – MDMarra Oct 31 '09 at 23:03
How did you upgrade? Did you download the ISO and booted from that (any chance you downloaded the server version then?), or did you use the Update Manager? Anything at that was different during your upgrade? – Arjan Nov 1 '09 at 9:20
startx gives "Fatal server error: no screens found" which made me lol as how would I have seen the error if there were no screens? I used the network upgrade using the update manager. – Gathris Nov 1 '09 at 11:35
It would be enormously easier to help you if you stated your hardware, most especially your video chipset. – CarlF Nov 1 '09 at 16:59

From Ubuntu forums , You may need to reconfigure your xconf by using the following command,

sudo dpkg-reconfigure -phigh xserver-xorg

PS: Added additional Solutions

1) try to fix xserver in the recovery options. 2) check your xorg.conf for device section

Section "Device" 
    Identifier "Configured Video Device" 
    Driver "radeon" ## or make it "ati"
share|improve this answer
Tried that from the recovery console and after login but did not fix the problem. – Gathris Nov 1 '09 at 11:31
How do I get to the recovery options? – Gathris Nov 1 '09 at 16:05
My 9.10 (which runs fine) does not have any xorg.conf file. I've read that /etc/X11/xorg.conf will be used if it exists though. So, just as a side note: to create such file, for example use sudo nano /etc/X11/xorg.conf (and when done, press Ctrl-X to stop). – Arjan Nov 1 '09 at 16:15
xorg.conf fie exists. is it still ok to run 'nano' command. – Gathris Nov 1 '09 at 17:24
Yes, nano is just an easy editor. You can always bail out using Ctrl-X and then select No when asked to save the changes (if you made any). – Arjan Nov 1 '09 at 18:08

Finally found the solution!

H/W: Dell Studio (1555) running Vista Home Premium 64bit; 4GB RAM; 250GB SATA (circa June 2009 B.FUTW7 [B.FUTW7 implies "Before Free Upgrade to Windows 7" LOL!] )

Booted USB version of Ubuntu 9.10 (x64) - worked perfectly. From there I installed to the HDD (last step ADVANCED I made sure the boot info was placed on the partition and to not modify the main MBR). After the installed it, I used EasyBCD 1.7 to get the boot to work - learning curve but worked fine.

But when I booted it went DIRECTLY to the console. I finally found THIS site.

First, I tried to start "xstart" and it returned "Fatal server error: no screens found" - a big clue!

So then I followed UK's solution:

sudo dpkg-reconfigure -phigh xserver-xorg

and then vi to change the

Section "Device"
     Identifier "Configured Video Device" 
     Driver "radeon" ## or make it "ati" 

Driver listed was "fglrx".

Funny, BEFORE the actual install, I downloaded the "ATI/AMD proprietary FGLRX graphic driver" - then I installed Ubuntu to the HDD. So I guess it used THAT as the driver but it failed to work.

I chose to rename the driver to "radeon" per the above and now Ubuntu loaded FINE!

Now back into the GUI, it said for that driver "this driver is not activated". Implies, perhaps, that my "attempt" to install during the "Test phase" remembered my CHOICE but didn't actually DOWNLOAD FOR THE INSTALL. So the new install used the "fglrx" driver in the xorg.conf but had not downloaded the drivers.

For a lark, I just downloaded the drivers using the "Restricted drivers" window ... once complete it changed the xorg.conf back to "fglrx" and I had to restart. NOW it worked fine and booted in GUI mode.

At any rate, a few hours from start (of d/l Ubuntu and installing it) to finish and now Vista and Ubuntu are working perfectly together.

Cheers all!

share|improve this answer

Does it go straight to a text login prompt, or does it flicker, trying to go graphical, and then fail back to a prompt? If there's no flicker, you probably don't have an X server installed. Install xserver-xorg and gdm.

share|improve this answer
Their is a flicker. – Gathris Nov 1 '09 at 8:39

If you have problems to start X, try the following:

if the command startx doesn't work, you have to reconfigure xorg.conf. You can do this by renaming the xorg.conf.failsafe file to xorg.conf. It is recommended to backup your old xorg.conf file before replacing it. Rename the original xorg.conf file by the following command:

$ mv -i xorg.conf xorg.conf.failsafe2

the -i option makes the mv command to promt when an exising file will be overwritten. Next type the following command:

$ mv -i xorg.conf.failsafe xorg.conf

now you can try to start X by the following command:

$ startx

It works with me, I hope it also works for you.


share|improve this answer
In which folder do the mv commands need to be executed? And wouldn't it need sudo? (And don't know if it matters, but on my fresh 9.10 install, without any problems, sudo find / -name xorg.* does not find any xorg.conf, nor xorg.conf.failsafe.) – Arjan Nov 2 '09 at 12:27

I have been having this exact same problems on my laptop since 9.10 was released and I tried to freshly install it. I was aiming to keep XP x64 on a separate partion, and load Ubuntu onto another. No command solutions worked, but this did work:

1) use a partition manager inside windows to create a NFTS partition (I used Partition Wizard - free and simple)

2) use Wubi from inside windows to install Ubuntu 9.10 onto the partition

3) boot and enjoy!*

*note: I had to reinstall the Windows boot loader from the CD because it had been over written by GRUB at previous Ubuntu install attempts, so if you're in the same boat, keep your Windows XP cd handy. I prefer to Windows boot loader to GRUB anyways.

share|improve this answer
I found a solution if you want to look at my original post. – Gathris Nov 4 '09 at 21:32

Type the below command

X -configure

After the above process completes, run file system consistency check by typing below command


After the file system check is completed, Reboot you linux box by typing

init 6

You will get GUI login, it worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.