Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded to Windows7 and I've found myself unable to watch recorded or live TV on Windows Media Center. The video quality is fine, but the audio is just an awfull synthetic sound - just to clarify, this is not poor audio but rather pure noise.

I find however that I'm able to play .avi files w/o issue. I'm not even sure how to go about solving this problem. Ideas?

Here are the stats of my setup:

  • Win7 64 bit, fresh repave, not an upgrade
  • Hauppuage WinTV HVR-1800
  • Over-the-air HD signal

I used gshow, and I get the following details

Partial Render Failure: The following is the error reported by DirectShow

0x00040242 [Unknown]

(Src)->>-(A)->[Decrypt/Tag]>-(B)->[AC3Filter]>-(C)->[Default DirectSound Device]

Update2:

I've uploaded a sample clip

share|improve this question
    
I don't have an exact answer, but I'm pretty sure it's something to do with the audio codecs Windows 7 comes with. I hear they're not very good quality. –  Sasha Chedygov Oct 31 '09 at 21:46
    
It's not poor audio but rather pure noise –  Scott Weinstein Nov 1 '09 at 17:12
add comment

1 Answer

up vote 1 down vote accepted

You can use K-Lite Codec Pack 64-bit.

This is a bundle of 64-bit DirectShow filters that can be used together with 64-bit players, such as Vista Media Center. This pack can co-exist without problems with the regular (32-bit) K-Lite Codec Pack.

EDIT

We were going about it backwards. The article Win7x64 Components 2.1.8 states:

2 versions of Windows Media Player exist on x64 systems. There is a 32bit version stored in \Program Files (x86)\ and a 64bit version stored in \Program Files\

x64 Windows uses the 32bit player as the system default. The installed components of this release include shortcuts to allow you to change the system's default player from the 32bit to 64bit player.

One other Aspect of Windows Media Player(s) on x64 systems needs to be mentioned. If you associate a particular filetype to Open With WMP while the system default is set to use the 64bit player, that filetype will always open the 64bit player when double-clicked. This occurs even if you change the system default back to using the 32bit player.

According to the above, you should actually install the 32-bits codecs.
I would try the new beta version of K-Lite Codec Pack 32bits, updated with Win7 features.

If still having troubles, you might install the above Win7x64 Components and see what it does in giving you more control.

EDIT2

To find the codec of a file, drop it into one of: GSpot or VLC (Tools / Media Information).

EDIT3

I found this thread, which recommends using the Vista Media Center Decoder Utility:

This utility will show you the current default decoders, let you select an alternative from a list of installed decoders and by pressing Set Default change the defaults

Others counsel the use of nVIDIA PureVideo Decoder or uninstalling FFDSHOW.

share|improve this answer
    
This didn't work –  Scott Weinstein Nov 1 '09 at 17:12
    
I tried both options. No luck. That said, not sure I'm using the right settings. –  Scott Weinstein Nov 1 '09 at 21:59
    
GSpot 2.70a is supposed to work on 64-bits. You might give it a go and find out which codecs it thinks you're using for audio. –  harrymc Nov 1 '09 at 22:12
    
I get the following info - Partial Render Failure: The following is the error reported by DirectShow 0x00040242 [Unknown] (Src)->>-(A)->[Decrypt/Tag]>-(B)->[AC3Filter]>-(C)->[Default DirectSound Device] Not sure what to do with that info –  Scott Weinstein Nov 2 '09 at 1:18
    
0x00040242 means "Some of the streams in this movie are in an unsupported format". So you're missing a codec. Any way for you to post some such file? –  harrymc Nov 2 '09 at 7:07
show 11 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.