Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Today I bought a SATA-to-usb convertor to copy my data from old hard drive that had been abandoned for few months. When I connected to PC, the partition didn't show up so I decided to fix the partitions. I was trying to recover the damaged parition from my WD hard disk drive using testdisk. I can see my 3 paritions when I 'Analyse' but when I Write those paritions it returns error:

Parition: Write Error.

I tried both Linux and Windows, both show same error. Now how do I sort this out , if not then is there another way to fix my partition tables?

   interface_write()
 1 * HPFS - NTFS              0   4  5  7230  82 20  116154880 [STR1]
 2 P HPFS - NTFS           7230  90 29 15120 113 33  126754304 [Local Disk]
 3 P Linux                15120 113 34 15200  30 62    1280000 [_Fedora-16-i686-]
write!

write_mbr_i386: starting...
write_all_log_i386: starting...
No extended partition

Partition: Write error
share|improve this question
    
I also get this "write error". WHat in the world!! I just want to recover my lost partitions. :( –  trusktr Nov 11 '13 at 23:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.