Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Debian unstable. My .asoundrc looks like this:

pcm.btheadset
{
   type plug
   slave
   {
      pcm
      {
         type bluetooth
         device 5A:5A:5A:A6:08:09
         profile "auto"
      }
   }
}

ctl.btheadset
{
   type bluetooth
}

I can play music through the headset, however I cannot control the volume.

$ alsamixer -D btheadset
ALSA lib audio/ctl_bluetooth.c:167:(bluetooth_send_ctl) Unable to receive new volume value from server
ALSA lib audio/ctl_bluetooth.c:161:(bluetooth_send_ctl) Unable to request new volume value to server: Broken pipe
cannot load mixer controls: Broken pipe

daemon.log has this:

bluetoothd[15628]: Invalid message: length mismatch

Any ideas? I suspected this may be some mismatch of binaries, so I tried downgrading bluez to Debian stable. No luck. Maybe I should try the same with alsa libs...

A lot of FAQs and tutorials suggest that PulseAudio should automatically solve this, however I installed it, it pulled down dozens of dependencies I have no interest in, and turned out to be a very user-hostile daemon that refused to play any sound at all. So I am not interested in that as a solution.

share|improve this question
    
You are invoking alsamixer correctly. Does your headset actually have mixer controls? This might be a bug in the bluetooth plugin. – CL. Aug 28 '13 at 17:08
    
@CL. - Not sure if the hardware supports it or not, or if it's a bug, but I've just discovered the "softvol" pcm type so now I'm happy. – asveikau Aug 29 '13 at 4:43
up vote 1 down vote accepted

Figured out a workaround. Using alsa's softvol plugin to do volume control in software.

Added this to .asoundrc:

pcm.btheadset_softvol
{
   type softvol
   slave.pcm "btheadset"
   control.name "Bluetooth"
   control.card 0
}

Now I tell software to play to the device btheadset_softvol and my main sound card's mixer has a "Bluetooth" option.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .