Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to setup a centOS server with a public static IP address but if I try and ping the router (192.168.1.1) I get "Network is unreachable", if I try and ping google.com I get "unknown host google.com"

This is the dump from ifconfig

eth0      Link encap:Ethernet  HWaddr D4:9A:20:F8:9D:F8  
          inet addr:200.37.213.113  Bcast:200.37.213.113  Mask:255.255.255.248
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1178 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1014 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:292875 (286.0 KiB)  TX bytes:40593 (39.6 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:249 errors:0 dropped:0 overruns:0 frame:0
          TX packets:249 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:20076 (19.6 KiB)  TX bytes:20076 (19.6 KiB)

Dump from route:

Kernel IP routing table 
Destination     Gateway          Genmask           Flags Metric Ref Use Iface
200.37.213.112  *                255.255.255.248   U     0      0   0   eth0
link-local      *                255.255.0.0       U     1002   0   0   eth0
0.0.0.0         200.37.213.118   0.0.0.0           UG    0      0   0   eth0

Dump from /etc/hosts

127.0.0.1             localhost localhost.localdomain localhost4 localhost4.localdomain4
::1                   localhost localhost.localdomain localhost6 localhost6.localdomain6
200.37.213.113        server.mypersonaldomain.com server

Dump from /etc/resolve.conf

nameserver 8.8.8.8
nameserver 8.8.4.4

Dump from /etc/sysconfig/network

NETWORKING=yes
HOSTNAME=server.mypersonaldomain.com
GATEWAY=200.37.213.118

Dump from /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE="eth0"
BOOTPROTO="none"
IPADDR:="200.37.213.113"
NETMASK="255.255.255.248"
GATEWAY="200.37.213.118"
ONBOOT="yes"
TYPE="Ethernet"

Any ideas where I'm going wrong here?

  • Update - I'm able to ping 200.37.213.113 and receive a response, but not 200.37.213.118 or any other domain/IP

  • Update - Still having troubles with this, does anyone else have any ideas?

share|improve this question
add comment

2 Answers

You're missing a default gateway which is demonstrated by your route "dump" so you're server has no way of sending traffic to a destination that is not a specific match within your routing table.

Dump from route:

Kernel IP routing table
Destination     Gateway    Genmask            Flags Metric Ref Use Iface
Your IP  *          255.255.255.248    U     0      0   0   eth0
link-local      *          255.255.0.0        U     1002   0   0   eth0

You can add a route to the outside world by setting a GATEWAY under your ifcfg-eth0 and bouncing the network service or eth0:

DEVICE="eth0"
BOOTPROTO="none"
IPADDR:="Your IP"
NETMASK="255.255.255.248"
ONBOOT="yes"
TYPE="Ethernet"
GATEWAY="Your Gateway IP"  <----
share|improve this answer
    
Thanks for the super-quick answer, I've updated the ifcfg-eth0 and added the gateway, restarted the eth0 and networking and still the same problem. Is there another route I need to add? –  user2672330 Aug 28 '13 at 16:59
    
Can you please update your question with your updated route output and if you're able to ping your default gateway? –  one.time Aug 28 '13 at 18:33
    
Done. It's placed a 0.0.0.0/Default route into the list, but hasn't appeared to fix the issue. –  user2672330 Aug 28 '13 at 19:25
1  
If you can't ping your default gateway you will remain without connectivity until you solve this issue. Is your server sitting on the same layer-2 segment as your gateway? Can you see ARP entries for these devices on the server or the device the server is connected? Can you tell us about your topology? (Also, while your attention to detail is great, I suggest you edit out all of the public IP address information in your post.) –  one.time Aug 28 '13 at 20:02
    
Alright thanks for the advice. I'm relatively new to networking so I'm not entirely sure about half of what you've asked for unfortunately, however It's given me a direction to look into which is a great help in itself. Basically I've got a router running DDWRT, then the server connected directly to that. I'm able to setup the server and get network connectivity through DHCP and the networks dynamic IP, but I want to assign it one of the 10 static public IP's provided by my ISP. I hope that helps explain better. Also the IP's in the post are fictional, thanks for the consideration though. –  user2672330 Aug 29 '13 at 2:38
add comment

If u r using GUI, u have to set up all the values not only in shell but also in GUI manually. Firewall. Try turn it off(also services iptables ip6tables) Turn off selinux. This prick make problems as well. If nothing of this work, let me know.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.