Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Sublime Text 3 package that will only work if a particular environmental variable is set. The env is currently set in my .bash_profile, so if I launch Sublime Text from the Terminal, this env is available to it. I'm on OSX.

However if I don't launch it from the Terminal it isn't.

So How can I make an environmental variable available to Sublime Text 3?

share|improve this question
1  
what operating system are you using? –  MattDMo Aug 29 '13 at 17:10
    
and what is the package? There may be an option to set the variable in a config file... –  MattDMo Aug 29 '13 at 17:49
    
@MattDMo It's unrelated to the package. Just happens that a quirk of my system means that for the package to run a command successfully it needs the Env to be set. –  1ndivisible Aug 29 '13 at 19:16
    
OK, but the more information you provide the better the answer will be. Can you at least tell us what OS you're using? –  MattDMo Aug 29 '13 at 19:22
add comment

1 Answer

use ~/.pam_environment

This file uses a special format: see http://man.cx/pam_env(5) , http://man.cx/pam_env(8)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.