Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set up a Raspberry Pi webcam server (running Raspbian) to be available publicly. I can see it internally when I go to its internal IP and port in a web browser. I can't get to it via the public IP, though.

The webcam server is connected to my wireless router, which is connected to my landlord's router via Ethernet cable. His router connects to the cable modem (Comcast). My router is a Linksys, but runs DD-WRT. My landlord's router is a Netgear with stock firmware. I have access to both and everything has always worked fine there.

I've tried forwarding the port in either and both routers, and with UDP, TCP, and both, but still can't access it externally. I edited /etc/motion/motion.conf on the Raspberry Pi to change DAEMON to ON and webcam_localhost to OFF.

What should I do? Ideally, I'd like the whole thing to be accessible over port 80 so I can just enter the external IP and see the webcam, but for now I'll settle for it to be accessible over a unique port.

Below is all the information I can (safely) provide. Please let me know if there's anything else I should include that I've omitted.

His router: Netgear WNR2000v3
Web access: 192.168.1.1
IP Address: 10.0.0.3
Subnet Mask: 255.255.255.0
Default Gateway: 10.0.0.1
DHCP Server: 10.0.0.1
DNS Servers: 75.75.75.75/75.75.76.76

My router: WRT54G running DD-WRT v24-sp2
Web access: 192.168.1.150
[WAN Setup]
Connection type: Static IP
WAN IP: 192.168.1.11
Subnet: 255.255.255.0
Gateway: 192.168.1.1
DNS: 75.75.75.75/75.75.75.76
[Network Setup]
Local IP: 192.168.1.150
Subnet: 255.255.255.0
Gateway: 192.168.1.1
Local DNS: 192.168.1.1
(DHCP disabled)

Webcam server:
IP Address: 192.168.1.17
Port: 8081

Thanks!

share|improve this question
    
A few questions: Have you reserved 192.168.1.17 in your landlords router? You would want to map it's mac address to that IP address. Once that's taken care of, try pinging 192.168.1.17 from your landlords router (if you haven't done so already). Let me know if it's reachable. –  graf_ignotiev Aug 29 '13 at 20:12
    
Is your router configured to actually act as a DHCP server, or do you just have it in bridge mode? –  ernie Aug 29 '13 at 20:42

2 Answers 2

Both of the networks are on the subnet (192.168.1.XXX), so your router is never going to pass traffic on your network to your landlord's network (unless your router is not actually routing). You should reconfigure your network to be on a different subnet (something like 192.168.2.XXX). These settings need to change:

[Network Setup]
Local IP: 192.168.2.1
Subnet: 255.255.255.0
Gateway: 192.168.2.1
Local DNS: 192.168.1.1
(DHCP disabled)

Webcam server:
IP Address: 192.168.2.17
Port: 8081
share|improve this answer

Assuming the possible network issue heavyd mentions isn't an issue, you would have to do something like:

  • Landlord's router - forward port 80 to 192.168.1.11, port x
  • Your router - forward port x to 192.168.1.17, port 8081

In other words, you need to forward from outside, through your landlords router, through your router, and finally to your webcam.

If your router is technically not acting as a router, and only a switch, then you just need to configure port forwarding on your landlord's router, and forward port 80 to 192.168.1.17, port 8081 (directly to the webcam).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.