Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed Debian Wheezy 7.1.0 on an Intel vPro System (Intel Core i5-2520M, SuperMicro MBD-X9SCV-Q-O). Intel AMT's KVM works perfectly until Debian has completed booting and shows the login prompt. At this point, the screen in RealVNC goes blank and after a minute, it dies with the following error message:

Error 0x80862000: Unsupported or inactive display adapter

Before it dies, while the screen is already blank, I can type my login info, and if I then type reboot, the server restarts. So, Debian is actually running as expected, just the display isn't working.

The system does not have any additional video cards installed, only the CPU-integrated one.

Here is what I think is going on: Debian detects that there is no monitor connected to the video card and then decides to switch the video card off to save energy (maybe some sort of headless mode). This in turn makes it impossible for Intel AMT to provide the frame buffer.

Assuming my assessment is right (otherwise please correct me), I am trying to figure out the following:

Is there a way (preferably a boot-time kernel option) to tell Debian to keep the video card enabled even if there is no monitor connected?

share|improve this question
    
Can you clarify the interaction between the KVM and RealVNC? And you're booting without the KVM switched to the system you're booting? What happens if you boot with the system active on the KVM? –  ernie Aug 29 '13 at 20:35
    
@ernie I'm sorry... I forgot to mention which KVM... Ooops... I'm using the KVM feature of Intel's built-in AMT feature (part of vPro). It's a hardware VNC server running in the processor/network-chip/BIOS. I turn the computer on via AMT and can then, in RealVNC, watch it POST and load Grub. Then, it shows the first couple of lines of Debian loading and when it gets to the point where it clears the screen to show the login prompt, the VNC window goes blank. –  Markus A. Aug 29 '13 at 21:22

1 Answer 1

up vote 1 down vote accepted

I found the following way to fix the issue:

  1. When grub shows the kernel boot choices, press e to edit the current boot entry.
  2. Find the line that looks something like this:

    linux /boot/vmlinux-... root=... ro quiet
    
  3. Add nomodeset to the end of this line, so it looks something like this:

    linux /boot/vmlinux-... root=... ro quiet nomodeset
    
  4. Press F10 to boot this configuration and everything should work fine for this boot
  5. To make this permanent, use your favorite text editor as root to open /etc/default/grub
  6. Find the line that looks something like this:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet"
    
  7. Add nomodeset to this line, so it looks something like this:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset"
    
  8. Save the file

  9. Run update-grub as root (Note: This will regenerate grub.cfg and probably overwrite any changes that may have existed there! Use with caution and maybe update grub.cfg manually instead of following steps 5 through 9.)

So the answer is: The nomodeset kernel option.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.