Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I run ipconfig /all, in the DNS field it is showing numbers such as fec:0:0:0:ffff::1%1, fec:0:0:0:ffff::2%1 and fec:0:0:0:ffff::3%1. nslookup www.google.com shows some kind of DNS error (lookup not found or similar). What does this mean and how do I fix it?

I haven't changed anything at the computer side. I am supposed to be able to connect to the Internet as soon as I plug in the cable but this day the Internet stopped working for some reason. So when I checked ipconfig I saw those strange values.

This is what ipconfig shows about DNS:

I didn't change anything recently in my system preferences.

share|improve this question
1  
ipv6? –  Khaleel Aug 30 '13 at 4:43
1  
I would look at the network adapter settings and see if IPv6 is on but IPv4 is not. This is DNS related. You should still be able to ping addresses like 8.8.8.8 and 4.2.2.2. In which case, internet is actually working, just not DNS resolution. –  R Hughes Aug 30 '13 at 4:50
1  
Could you please try disabling ipv6 here? –  Khaleel Aug 30 '13 at 4:51
    
it sounds like there is moregoing on here. The list of things to check will be quite large and we don't have much to go on yet. Try some of the things listed here to start and try to narrow down the problem more. howtogeek.com/126265/… –  R Hughes Aug 30 '13 at 5:03
    
The DHCP server you are connecting to appears to be handing out IP6 DNS addresses. That's where your strange letters are coming from. –  R Hughes Aug 30 '13 at 5:05

4 Answers 4

You are indeed using IPv6. This is the default address, something like the 169. addresses in IPv4 that Windows uses and indicates that you could not find a DHCP server when your machine requested a new address.

If you do an ipconfig /renew do you pick up a real address? Did you make changes recently to the networking configuration? Is this a home or work network and are other clients on the same network still able to resolve?

Please post the entire contents of ipconfig /all

share|improve this answer
    
I reset the router and switch and that seems to have solved the problem. While it's working, it look s like the DNS is two ipv4 addresses. So now I am sure it has to be ipv4 to be working. –  user13267 Aug 31 '13 at 2:04

Somehow you have enabled IPv6 on your node. Those are default IPv6 "site local anycast" addresses for DNS that Microsoft configures automatically if no other IPv6 DNS addresses are configured. They are obsolete (site local was deprecated in 2004, see Wikipedia). See also the IETF draft IPv6 Stateless DNS Discovery.

They are kind of like link local (fe80::), but can cross internal routers (link local won't cross any router). Microsoft DNS servers will accept DNS connections to any of those addresses, so this allows IPv6 DNS to work without any additional configuration. Not all DNS servers accept these.

Anycast means you can have several servers all publish the same address, but only one will actually accept any given connection from a client (different from multicast and unicast). Anycast is something new in IPv6.

You probably aren't actually using IPv6, so I suggest you configure some IPv4 addresses for DNS. You may want to disable IPv6, although somehow your node thinks it is available to you. Perhaps your ISP has started routing it to you - most will be doing that sooner or later. You should start learning it now, as IPv4 is on the way out - within a couple of months all the major RIRs will be out of public IPv4 addresses - the only public addresses available will be IPv6 from then on (except in very limited number, for very high prices). All but ARIN (N. America) are already out - APNIC ran out back in early 2011.

share|improve this answer

I KNOW THE PROBLEM!

You have Hamachi downloaded am I not mistaken? Your looking at the wrong part of the ipconfig! I just figured it out! Scroll up a litttle more to find your actual router config!

share|improve this answer
    
Thanks. Don't know what's up with the downvotes... but it was true in my case –  Brett Jun 11 '14 at 22:03

go to your advanced adapter settings through the network and sharing center. uninstall all protocols, services, and clients. Then, install each group of them in this order: protocol service client

then click 'diagnose'

the issue should resolve itself.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.