Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Eclipse, Ctrl+Q shortcut forces application closure. There are no warning messages AND if going to Windows -> Preferences -> Keys, there is nothing bound to Ctrl+Q and even if I bind something, it does not prevent closing.

share|improve this question
    
I have the same exact problem on the latest Eclipse version (Kepler). –  Howie Aug 31 '13 at 13:01
add comment

1 Answer

up vote 1 down vote accepted

I tried this trick and it worked for me, (Kepler Version)

Go to Windows -> Preferences -> Keys.

Search for Close, you will see two close shortcuts Ctrl+F4 & Ctrl+W
Select any one Close command & Now Click Copy Command, so you will see another Close Entry with no Key binding.

Click the newly created Close command (that will have no binding now, i.e. Blank in the Binding section). Now in the Binding section, assign Ctrl+Q as your bind. Click Apply. Recheck in Eclipse whether Ctrl+Q is closing your application / opened files. It will close.

Again now go to Windows -> Preferences -> Keys.

Search for Close, and Locate the binding which you have created Close --> Ctrl+Q. Click that and select the Unbind Command. Press Apply. Now Ctrl+Q will do nothing.

Hope that helps.

share|improve this answer
    
It worked partially: everything like you said caused Eclipse to close, but when I unbinded every single entry found for "Close", I was then able to make Ctrl+Q "Close current tab". It is better than closing entire worspace and waiting for background workers to finish their cleanup :) Thanks for the idea. –  Xeos Sep 10 '13 at 21:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.