Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to use TV8 between my home & work PCs (both running win7 pro). The problem is that my work pc is configured to lock after 5mins of inactivity and to relog back again you have to press Ctr+Alt+Del and insert your password.

The above feature seems to prevent TV8 from remote control, even if the application is still running inside the locked session with admin rights.

All I get is the message

enter image description here

The screen cannot be captured at the moment. This is probably due to fast user switching or a disconnected/minimized Remote Desktop session.

Is there a workaround on this?

share|improve this question
Have you asked your IT Department if they can change this policy on your PC? – Moses Aug 30 '13 at 18:21
You can use the built-in Remote Desktop Client built into Windows more then likely. Teamviewer is limited. There is unlikely a solution that involves TV8 that doe snot involve changing the policy itself. – Ramhound Aug 30 '13 at 18:51
@moses Unfortunately I think thats not an option.. but my question remains: Can TV connect to a locked session? (the same as pressing WindowsKey+L) I read somewhere that was possible in WinXp.. – LePhleg Aug 30 '13 at 18:53

8 Answers 8

TeamViewer needs a running service on the remote PC if you want to connect to a locked session (depends on the Windows version though). The service should be installed if you install TeamViewer.

share|improve this answer

Did you try this on your work PC?

:teamviewer: options -> security -> windows logon -> allow all

share|improve this answer
No I havent change any settings. But I can see that the default option is "Allowed for administrators only". My work PC user is an administrator user.. – LePhleg Aug 30 '13 at 19:03
That's strange. Does it work when you are not logged off? So we can rule out a weird firewall issue. And are you sure you are a admin and not a power user. You could test switching the permission. – jansmolders86 Aug 30 '13 at 19:11

I had the similar issue and just got help from teamviewer support that worked. here it is

Please activate the following setting in your TeamViewer options in TeamViewer --> Extras --> Options --> Advanced --> Show advanced settings --> General advanced settings --> [ ] Enhanced multi user support

This function makes it possible for TeamViewer to get different TeamViewer Ids in different sessions (User/Server session) and can also resolve issues with fast user switching.

Please make sure to connect to TeamVIewer server id --> TeamViewer --> Help --> About

when you have the server ID create a new connection based on the server id from your home computer.

share|improve this answer
what version are you using? i can't find the multi user support in any of the advanced settings on teamviewer 9 – Mickey Perlstein Sep 22 '14 at 19:48
tv 9. host tb on the vps, accessed by normal desktop tv 9 – ondrobaco Oct 3 '14 at 5:05

I know my answer is pretty late but I let this in case someone else is having the same issue. The server that you're trying to connect has to have Teamviewer automatically start on windows logon (that option appears when you install the program) so it can create the teamviewer as a service and then allow teamviewer to automatically "turn on" the computer. (You need to reboot if the installer asks, so if is a server it's pretty hard to do it)

share|improve this answer

Can you check if you have any remote desktop connection opened in the workpc machine in minimized state .If it is please disconnect any unused remote desktop session from the work pc and check whether you are able to connect from your pc without any errors.

Usually locked screen can be unlocked using the option from the teamviewer interface by going to the menu from actions -> ctrl+alt+del.This wont play role in giving this type of error

share|improve this answer

Go to Actions -> Remote reboot -> log off then you'll get disconnected.

Now login with the same user id and password and this will resolve the issue.

share|improve this answer

There are two kinds of TeamViewer "ID":s. User ID and Server ID. When setting up unattended access on newer versions of Windows Server, I had extreme problems with getting it to work without first having a logged in user on the server, and minimizing the RDP session or closing it resulted in this annoying error message about The screen cannot be captured at the moment.

The solution is to:

  • enable the Teamviewer service to access the desktop (check the box "Allow service to interact with desktop", under the the "Log On" tab on the service in services.msc)
  • enable multi user support in Team Viewer (Extras, Options, Asvanced, Show advanced options, General Advanced Settings, Enable enhanced multi user support (for Terminal Server))
  • Use the Server ID, not the User ID, when connecting.

The Server ID can be found by clicking the blue exclamation mark right next to the User ID on the main panel.

This works on Windows Server 2012 R2, and most likely older as well.

share|improve this answer
There is no "Enable enhanced multi user support (for Terminal Server))" in my TV version 10. Maybe it appears only for server Windows versions? Also there is no blue exclamation mark next to the ID (it says "Your ID", not "User ID"). – David Balažic Oct 11 at 12:28

You need to add TeamViewer program as a basic task in Task Scheduler Window (search from Start menu) then do configure the options for the basic task.

Useful options are start the task (in Task Trigger) when the computer starts to open, run the task that executes the program whether the user is logged on or not, hide the task (optional), wake computer to run the task, etc..

Simple as that!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.