Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

First of all, I'm confused about system structure. It says that root path (/) has only 6.5 GB of free space, but when I go to /media/my_username, I enter New Volume which is I believe name of my physical memory hdd. It says it has 35 GB of free space.

I'm guessing the answer, but I want to be sure.

Second thing: I want to use that 35 GB of free space and assign it to Linux Filesystem. I tried with

lvextend -L+1G /dev/sda1

...but it says...

Path required for Logical Volume "sda1" Please provide a volume group name

...but when I tried...

vgdisplay

...I got...

No volume groups found

...and...

resize2fs /dev/sda1

...gives me...

Bad magic number in super-block while trying to open /dev/sda1

I alse used df -hT and found out that /dev/loop0 is mounted on / but, again, I have to provide volume group name.

share|improve this question
    
Please post the output of sudo fdisk -l, your explanation of free space is not clear. –  terdon Aug 31 '13 at 13:45

2 Answers 2

up vote 0 down vote accepted

It looks like you have a basic misunderstanding about partitions and LVM volumes.

In order to use LVM, (physical and logical volumes), you need to prepare the LVM system first. For the / (root) filesystem, this done during system installation. If you didn't do this at that time, you can not extend the / filesystem.

But you can have multiple filesystems, and I guess this is what you have at the moment. If you type just

mount

in a terminal, it probably will contain something like

/dev/sda2 on /media ...

in it's output (among many other lines).

share|improve this answer
    
I tried mount and got "/dev/loop0 on / type ext4 (rw,errors=remount-ro)" Is this mean that I have LVM system prepared or? This really confuses me :/ –  Bade Aug 31 '13 at 13:13
    
No, probably not. LVM looks more like /dev/mapper/vg_something on / type ... but this depends on your distribution. /dev/loop0 really seems a bit strange unless booting from a live CD. What is your distribution ? –  Markus N. Aug 31 '13 at 13:47
    
BTW: You can get info about your loopback device using losetup -a –  Markus N. Aug 31 '13 at 13:54
    
I'm not booting from live CD. I have Mint. Here's printout of losetup -a: "/dev/loop0: [0811]:37714 (/host/linuxmint/disks/root.disk)" –  Bade Aug 31 '13 at 15:07
    
Unfortunately, I have no detailed knowledge about Mint and it's specials. But /host/linuxmint/disks/root.disk does not at all look like a LVM volume. You can try vgdisplay and if output is empty, you definitifely have no volume groups prepared. Maybe I should be a bit more precise about "preparing LVM" ... It is not sufficient to install the LVM tools. You need to explicitely create PV's, VG's and LV's on your disk while it is empty and choose a LV for / filesystem during install. You can not convert it afterwards. –  Markus N. Aug 31 '13 at 15:27

A first partition is mounted on the root folder denoted by a single slash. All other partitions are mounted under arbitrary subfolders under root such as /mnt/media, /mnt/cdrom, /usr/local/share or even /usr and /var.

The commands you are trying to use are designed to work with LVM partitions. They are logical volumes that reside within a volume group which are comprised of one or several physical volumes. In order to resize an LV, the PV must have free extents. This is assuming that the partition you are trying to resize is indeed on an LV block device. Chances are you have standard, "flat" partitions right on top of the hard drive without an LVM level in between the partitions and the actual media.

ref:

Red Hat - LVM architecture overview

share|improve this answer
    
Although I have 2 HDD, I don't use the 2nd one, so I only need to assign some free space from /media to /. So are there commands that resize LV of the same PV or should(can) I make OS believe that my two partitions are two PV? –  Bade Aug 31 '13 at 9:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.