Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I woke up today and when I turned on my computer, I noticed that there was a terminal window open. It said the following:

Last login: Wed Aug 28 16:44:16 on console
mary-iMac:~ mary$ 

The terminal heading was: byname - bash - 80x24

I know I didn't open this window...is it possible I'm being hacked? I've suspected something was up and installed Avast, but not sure if that's enough. I'm in the habit of now turning off my network when I leave my computer, but that also may not be enough.

share|improve this question
    
Do you have a cat? Could anyone have used your computer? There is nothing malicious in the text you describe, that is normal for an opened terminal. –  terdon Aug 31 '13 at 13:30
    
Nope, no cat. Just a Lucky Bamboo plant that tends to stay put. Thank you for your reassurance. I'm not as well versed in these things as I should be, but I do hope to rectify that in the near future. Again, thank you for your response. –  Mary Aug 31 '13 at 14:14
    
If that window is still open, you could type history and see if there were any other commands entered, but I agree with the others that it probably just got clicked on accident. Do you have the Terminal in your dock? If someone remotely logged in, it wouldn't open a window that you could see. –  beroe Aug 31 '13 at 16:19

1 Answer 1

It only means that the Terminal app had launched for some reason and if all your running apps on shutdown relaunch on system start, Terminal probably did the same. You may have launched the app accidentally or someone else using your computer might have did so or on purpose.

Terminal is just an app that allows user control computer by typing in commands instead of clicking on buttons and so. If someone had connected to your computer remotely or ran some shell script Terminal app wouldn't launch.

But to make you sure remote connection to your computer isn't easily possible make sure you have unticked "Remote Login" & "Remote Management" checkboxes in System Preferences > Sharing

share|improve this answer
    
Thank you very much for your response! –  Mary Aug 31 '13 at 13:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.