Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've started using a Technika LCD TV with my PC and, while it displays full OS graphics, the text that is usually displayed during boot up (with the exception of the initial BIOS screen) does not show - the screen goes blank. I can sometimes see text for a brief fraction of a second before it disappears from the screen.

The TV's on-screen display menu will also not show during times when the text does not show but it occasionally shows a "No signal" message. The OSD menu will display again as soon as the OS graphics appears.

The main problem this causes me is when I test a new graphics driver in Ubuntu and it fails I cannot see any text on the screen to type command line instructions.

From some initial research I know that video cards can output in two modes - text mode and graphics mode.

Another situation that involved a blank screen output was while playing a 3D game in full screen. I changed the game resolution mid-game and the screen went blank.

Please clarify why this problem is happening and tell me how I can use the console when the Linux graphics driver fails to load. Thanks.

UPDATE I am pretty sure it is to do with my HDTV not supporting the resolutions being used in each blanks screen scenario. Can this be fixed in Grub? See Reducing video mode switching during Linux boot. I am unsure about Grub and its settings.)

Technical info: Nvidia GeForce 9600 graphics adapter connected to a Technika LCD 32" TV via a VGA cable connected to a DVI adapter/port on the computer. My working resolution in Ubuntu is 1360x768 but according to the TV's OSD menu the TV is operating at 1280x768 resolution.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Maybe your text console display has a resolution/timing yout LCD TV does not know (yet). You can test this by bootung Ubuntu and after graphics mode is ready, pres Ctl-Alt-F1 to switch to the first console (maybe first is occupied, then try Ctl-Alt-F2).
Then try to Auto-Sync your LCD-TV. Mine has a key for it, maybe your's, too. Otherwise search the TV's menus for an aut-Sync option.

A HDMI/DVI cable is likely to help (if it's a resolution problem), but I am not sure enough to propose buying one without previous testing. Can you borrow one frome one of your friends ?

EDIT:

Interestingly, my TV has a native resolution of 1280x768 and I had trouble setting my X server to exactly this resolution. In the beginning, I could only have either 1280x720 or 1024x768, both being stretched to fullscreen. And I still am unable to set this resolution on the console and the bootsplash.
The reason is that 1280x768 is a rather unusual resolution.

I am using AMD onBoard graphics, so my suggestion may or may not work on your PC. What I know is that the modesetting differs between AMD and NVidia. So you may need to do some more research for the details.

My suggestion is to try and set the console resolution to 1024x768 in /etc/default/grub and do an update-grub. With my AMD graphics, I can just specify GRUB_GFXMODE=1024x768. Maybe you need to determine the video mode number with your NVidia.
If you see a grub menu but no console when Linux starts booting, you should try to set GRUB_GFXPAYLOAD_LINUX=keep to make the Linux kernel keep the resolution from grub. The GRUB_GFXPAYLOAD_LINUX is from ArchLinux (I'm experimenting with) but should work on Ubuntu too. If it works, it will be stretched a bit too, but I think on console, this is not very bad. And better than nothing. ;-)

share|improve this answer
    
Unfortunately, I can't get into Ubuntu. I'd use a computer monitor to test but my monitor broke. I might have to try and borrow a monitor but it would take a while. –  authentictech Sep 1 '13 at 12:19
    
The menu only provides an auto-position option but not an auto-sync option. I have some other menu items: H-Position, V-Position (obvious what they are), Phase, and Dot Clock (no idea what they are but they seem to auto-adjust). I added some detail to the question - the OSD menu won't display during the problem output mode - it just disappears (not a timeout issue because I am moving the options around as it happens). I can guess the correct key presses to select options to boot into Windows safe mode (this is when the display goes blank) and then the TV menu comes back when Windows loads up. –  authentictech Sep 1 '13 at 12:24
    
You can step through the TV's menus to the auto-position item while having output and "learn" the steps (e.g. menu, down, OK, down, right, down, ...) and then do it blind when the problem shows up. –  Markus N. Sep 2 '13 at 10:43
    
A good idea but, unfortunately, the auto-position didn't do anything to rectify the situation. –  authentictech Sep 4 '13 at 10:54
    
I've rewritten the question with what I think is better additional info. Also, having got my graphics driver working again in Ubuntu, I pressed Ctl-Alt-F1 and Ctl-Alt-F2 (up tp F6) and both produced blank output and a "No signal" message on the TV's OSD. –  authentictech Sep 16 '13 at 1:15
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.