Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

First time here. I have bought e530 with windows 8 and the first hour of work with it i have a problem.

I have ssd with windows 7 which i want to use with my new e530. I have made a sysprep of win 7 and installed ssd to the e530. The HDD which was inside e530 i want to use as second hdd instead of my DVD Drive.

I connected this HDD through usb-to-sata adapter to copy some files from ssd to the hdd. Unfortunately it didn't see the file system on the HDD (but first time i have booted to it and first boot into Windows 8) I've made some mistakes and i corrupt the filesystem on the hdd.

I tried bunch of tricks to recover the GPT, but it didn't work. I have managed to recover the Lenovo_Recovery partition to my ssd using recovery tools.

And now I'm stuck, with this new things to me - EFI, GPT, etc i don't how this stuff works, and i have been trying to understand this for hours - but nothing seems to work. I want to restore the Windows 8 to the hdd, so it is there alive.

What i have done so far:

  1. Formated the HDD
  2. I took the PBRALL file from the Lenovo_Recovery
    " convert gpt
    create partition Primary size=1000 ID=DE94BBA4-06D1-4D40-A16A-BFD50179D6AC
    gpt attributes=0x8000000000000001
    assign letter=W
    format quick LABEL=WINRE_DRV
    create partition efi size=260
    assign letter=s
    format quick fs=fat32 LABEL=SYSTEM_DRV
    create par msr size=128
    create partition primary noerr
    assign letter=t
    format quick LABEL=Windows8_OS
    shrink desired=12197
    create partition Primary ID=DE94BBA4-06D1-4D40-A16A-BFD50179D6AC
    gpt attributes=0x8000000000000001
    assign letter=q
    format quick LABEL=Lenovo_Recovery "
  3. it recreated the partitions
  4. copied contents of SDRIVE.zip to SYSTEM_DRV partition
  5. copied contents of WDRIVE.zip to WINRE_DRV partition
  6. Copied restored Lenovo_Recovery back to Lenovo_Recovery partition

So now I have 3 system partitions: SYSTE_DRV
BOOT
boot.sdi
EFI
BOOT
bootx64.efi
LenovoBT.efi
Lenovo
...
Microsoft
...

WINRE_DRV\Recovery\WindowsRE\winre.wim

Lenovo_Recovery (whic contains install.wim and bunch of other things)

So i put back the HDD inside the laptop and tried to boot - but nothing works. It just doesn't boot to anything - no errors - nothing at all. When I choose this HDD manually for boot - just black screen blinks and that's all - it returns back to the devices boot menu.

SYSTEM_DRV is EFI partition, so I don't understand why it doesn't boot, it has files needed inside.

Can anybody tell me what should be done to make it boot to recovery console or smth like that? How to restore the Windows 8 from the Lenovo_Recovery install.wim image? As I understand I have all the files where they should be, but why it doesn't work? How to troubleshoot such things?

Also, if somebody has good link where EFI booting process is explained in details that would be great. Cause i still don't understand how it knows what partition to boot?

share|improve this question
add comment

1 Answer

Okay, I can't say for sure but if Lenovo is anything like Toshiba their recover images are just that, recovery not installation. Okay, since you seem really confused and messed a lot of stuff up I think it's best to start over. Since (assuming Lenovo is like Toshiba again) you don't want to order / wait for the real recovery media then we're gonna use this ISO. It's an OEM version of the Non-pro windows 8. If your system has pro then you need this ISO (Only tested the first one because I don't have a PRO machine yet here's a second 64 bit only). Now you're going to have to download and burn the ISO to a CD using another machine. From here we slap in the install CD. From here we go through the instructions. At one point it will ask you to choose a partition / drive. There should be an advanced options or something similar when you click on a partition / drive. First find the SSD and reformat that completely. Nothing on it at all by choosing the "reformat the drive" or deleting all the partitions. Then you install normally.

Now lets take a trip back down memory lane assuming this worked. You'll find that Windows 8 will not boot in a sense from a USB drive (I say in a sense because you can do an install boot like you can from the CD but not a true live CD / USB boot this way).

The wonderful thing about windows 8 (considering it seems this machine already had it and such) is that it will auto authenticate using your UEFI. On top of that it will do all the partitioning for you. Try that with Arch Linux and you'll blow your brains out faster than you'd like to admit.... trust me I've tried.

share|improve this answer
    
thanks for answer, but i think i resolved the issue. Partitions are not visible for boot, cause I have formated the drive when using USB-TO-SATA adapter, and was booting from SATA. I checked today and when on SATA it doesn't see the partitions. I think it should be some problem with USB-TO-SATA working with GPT, there is some offset or smth like that. –  anderhil Sep 1 '13 at 17:40
    
@anderhil Yes, if you look at the answer I said you can't boot Windows 8 with a USB anything. –  Griffin Sep 1 '13 at 18:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.