Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I hid the Emacs toolbar with (tool-bar-mode -1), but the toolbar appears again when the window is maximized.

I'm using Emacs 24.3 (9.0) on Mac OS X 10.7.5.

How can I remove the Emacs toolbar in any window size?

share|improve this question
2  
Please try with a .emacs file containing ONLY the following entry and then report back with the results: (tool-bar-mode 0). You want to rule out other possible explanations, so that is why you are using a virtually empty .emacs file to run your test. –  lawlist Sep 1 '13 at 14:10
    
Following the idea of @lawlist, you can run emacs -Q so it is loaded without the .emacs and then in the *scratch buffer do C-x C-e when the point is at the end of (tool-bar-mode 0). –  Dror Sep 2 '13 at 6:36
    
By maximized, do you mean full screen? I have also disabled tool-bar-mode, and Emacs.app shows a 18 pixel tall white area at the top of full screen windows. Do you mean that or does it also show the icons or something? –  Lri Sep 2 '13 at 9:34
    
Thanks for your advises! At first I only disabled by eval-last-sexp the (tool-bar-mode -1). But when I restarted Emacs, the toolbar is disabled with fullscreen mode also. I should have restart before I ask here. Sorry and Thanks. –  Tetsu Sep 5 '13 at 8:36
    
And the mention above (I can't read his name.), There is a white space around 20px and there is another 20px white space that I don't need. Do you know how to remove the white space, or should I ask in another question? –  Tetsu Sep 5 '13 at 8:40
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.