Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I search for something using the Google search engine on Firefox's top right, it first checks www.google.com which then gets redirected to www.google.co.in. When I'm on a slow connection, this unnecessary redirect adds a few agonizing seconds to every search I perform.

How can I change it so that Firefox uses a google.co.in URL by default? I get a Add <SiteName> option when I'm on other sites (e.g. right now I have Add SuperUser) in the list of search engines, but visiting google.co.in doesn't give me such an option. Is this a hard-coded exception in Firefox? How can I circumvent this?

share|improve this question
    
possible duplicate of How to add a custom search engine to Firefox? –  Bob Sep 1 '13 at 12:28
1  
Especially note the answers that point to resources such as this one, which let you search from an existing list or create your own search plugin given a URL. In fact, it looks like a Google India one already exists, though that one doesn't have a suggestions URL set. –  Bob Sep 1 '13 at 12:30
    
@Bob Thanks. I knew the keyword search method mentioned in the top answer there, but that's relatively cumbersome, I'll check the other options given. –  sundar Sep 1 '13 at 12:50
    
@Bob The linked engine searches only among "pages from India" which I don't want, but the "Google IN-en - the web" one on mycroftproject.com/search-engines.html?name=google.co.in works very well. And suggestions too work on this one (mycroftproject.com/installos.php/13836/google_indian_en.xml) Thank you very much for pointing me to that site. –  sundar Sep 1 '13 at 19:14
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.