Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this problem when my macbook air sometimes does not connect to free wifi hotspots. When the problem happens and I try to run the diagnostics, it normally gets to yellow network settings tab. It seems that it for some reason does not acquire automatically the router or dns address. Sometimes after I shut it down and restart it magically connects to the wifi hotspot but it is very inconsistent. Anyone knows a fix for this problem?

share|improve this question
1  
do you see this with any other devices on the same network(s)? –  warren Nov 16 '10 at 2:44
    
I am having this same problem on my MacBook Pro; seems like it's not model-specific. –  squircle Dec 29 '10 at 2:46
    
>2k views and no votes? What is this madness? –  tyblu Dec 29 '10 at 4:46
    
what about a windows/ubuntu/smartphone? do they also have a problem? –  Pulkit Sinha Dec 29 '10 at 7:36
    
@thepurplepixel: Not responding to the suggested answers means wasting your bounty rep-points for nothing. –  harrymc Jan 2 '11 at 19:18

4 Answers 4

You may want to try changing the service order. What effect this actually has, I'm not positive, but it's worth a shot:

  1. Go to System Preferences and click Network under Internet & Network
  2. Click the little options button under the services list and choose "Set Service Order...".

    little options button

  3. In the list that pops up drag your wireless service, likely called Airport, to the top.

I've heard some claims that this is caused by TCP packet timestamps not agreeing, but I can't find the link (great). Maybe something related to this.

share|improve this answer
    
Service order is basically what connection to prefer when there are multiple connections available, which is not the case for me. Also, I don't know if it has to do with the timestamps not agreeing, because when I look at Wireshark, there aren't any ACKs from any TCP packets on my computer. Oddly enough, I think this may be a DHCP issue, as when I set a static IP, I can connect fine, but only for 10-15 minutes. –  squircle Jan 2 '11 at 19:56
    
@thepurplepixel, I have the same problem, though lately it doesn't seem to be surfacing. Maybe one of the recent updates fixed it for me. Maybe the neighbors turned down their MegaMechaMicrowave furnace. The way I avoided the problem was listening to a radio stream on iTunes and turning the volume all the way down. The constant stream seems to keep the internet demons (daemons? ;) at bay. –  tyblu Jan 3 '11 at 0:04
    
@thepurplepixel, Also, I know what the primary purpose of Service Order is, but there appear to be secondary effects in changing it. For example, my improved wireless connectivity. ;) –  tyblu Jan 3 '11 at 0:06
    
Thanks for the suggestion; I'll try it out. –  squircle Jan 3 '11 at 0:07
    
I cannot fathom why, but this seems to have fixed the problem for me. Thank you so much for your suggestion! –  squircle Jan 4 '11 at 0:43

Free wifi hotspots are notoriously flakey. Does your machine ever exhibit this behavior with a reliable wireless network such as your home, a friend's, or your office?

First run Software Update to make sure you are up to date with all your Apple Software.

If that doesn't do it then make note of what your network and energy saver settings are by taking screen shots. Make note of locations, VPNs you have set up, timers for turning on comp, etc.

Navigate to the directory /Library/Preferences/SystemConfiguration

Note that this is the Library at the root of the drive, not in your user folder.

Copy that folder to your desktop as a backup. You will have to authenticate as an admin user.

Delete the entire SystemConfiguration folder. It will contain about 8 files. You will have to authenticate again.

Reboot the computer.

Set up your network and energy saver to your liking again and you should be good to go. You will have to manually join each wireless network again as you come across them, but this procedure does not remove any saved passwords for WiFi networks—they are still in your keychain.

Runing verify disk in Disk Utility (in your Utilities folder) and checking your drive with Disk Warrior (commercial app) could also help.

This isn't guaranteed to fix it, but is essentially starting you with fresh Network settings and will likely work. If the folder deletion, Disk Utility and Disk Warrior don't fix it I would reinstall the latest combo updater from apple on your machine. After that it sounds like an archive and install of the OS would be necessary, and if that doesn't do it there may be a hardware problem, possibly with the airport card.

10.5.8 Combo Updater http://www.apple.com/downloads/macosx/apple/macosx%5Fupdates/macosx1058comboupdate.html

10.6.1 Updater (there isn't a combo out yet until it hits .2) http://www.apple.com/downloads/macosx/apple/macosx%5Fupdates/macosxv1061update.html

share|improve this answer
    
yes, it does - it's come to a point that I have set up locations with manual settings for home and other networks I use on regular basis just to avoid the frustration. I guess I mentioned "free wifi" just to emphasize that it is not a login or access problem. –  Rumsfeld Nov 1 '09 at 18:39
1  
I've done all of the preference resets and permissions checks, but the issue still persists. I hope it isn't hardware-related. –  squircle Jan 2 '11 at 19:58
    
Can you connect if you are logged in as another user? How about if you have a clean OS on an external drive booted via Target Disk Mode. support.apple.com/kb/ht1661 That will eliminate the possibility of software problems in your user and in your OS install. If you have the same problem with these two then it is a hardware problem. –  ridogi Jan 15 '11 at 4:16

You could try setting IPv6 to OFF :

System Preferences > Network > Advanced > TCP/IP : Configure iPv6: Off (local only)

You could also try disabling flow-control :

System Preferences -> Network -> Advanced -> Ethernet -> Configure Manually -> Change "Duplex" setting from "full-duplex, flow-control" to just "full-duplex"

share|improve this answer
    
Flow control only applies to wired ethernet, which I have no problem connecting through. The only change-able option in the advanced settings for a wireless adapter is the MTU, which is set at the standard 1500. Also, I have IPv6 off by default and the problem persists. When I look at Wireshark, I just see a bunch of DHCP Discoveries being put out, as well as some broadcast (255.255.255.255) traffic from the network (not broadcast like 192.168.0.255/24). –  squircle Jan 2 '11 at 19:53

Try removing all any custom DNS settings (OpenDNS, Google DNS, etc.). I find that sometimes having those entries prevents the machine from getting an IP.

share|improve this answer
    
I have no custom DNS setup in the network profile I use when connecting to these networks. –  squircle Jan 2 '11 at 19:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.