Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a master running Ubuntu and a Slave running Mac OSX 10.6.8. I set up the SSH keys. When connecting to the GIT repo directly from Slave, everything works well and I am not asked to enter a passphrase.

However, when I first SSHed from Master to Slave and then try to connect to the GIT repo, I am asked to enter the passphrase at each command. What should I do to solve this?

Summary

terminal-->Slave--SSH (a)-->GIT repo ==>> NO passphrase asked in (a)

terminal-->Master--SSH-->Slave--SSH (a)-->GIT repo ==>> passphrase asked in (a)

share|improve this question
    
In the second case, your terminal doesn't know about the ssh-agent that stores the SSH key (therefore not requiring to type the passphrase again). See also superuser.com/questions/141044/… –  eldering Sep 2 '13 at 9:18
    
Excellent, it seems to be working! Now, I need to find a way to tell Jenkins to use the "-A" flag;) Thanks! –  Korchkidu Sep 2 '13 at 9:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.