Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got a Western Digital My Book external hard drive that are a couple of years old. I tried to get it running via eSATA the other week and when I was about to try it again the disk itself never spin up. Maybe it did not like that I hot swapped it a number of times.

The LEDs at the front just flash (3 out of 4) and the drive is silent. I suspect that something in the controller board might have broke down, or the disk itself has crashed.

Any suggestion on how to troubleshoot this? I plan to move the hard drive itself to a computer and see if it's working that could rule out a HD failure. Also I tried the disk connected via eSATA, USB and Firewire. Also tried to start the disk while not connected to more than power cord. Same result.

Thanks in advance.

share|improve this question
    
"I plan to move the hard drive itself to a computer and see if it's working that could rule out a HD failure" -- OK soooo why haven't you done that yet? –  Ƭᴇcʜιᴇ007 Sep 2 '13 at 16:39
    
@techie007 I wanted to check if there was something else I could try first before risking to destroy the casing in the process of cracking it open. –  Qben Sep 2 '13 at 16:47
    
It's broken as-is, why you worried? :) –  Ƭᴇcʜιᴇ007 Sep 2 '13 at 16:50
    
Well, you know hope and stuff. :) –  Qben Sep 2 '13 at 17:44
    
The drive actually started by itself after it had been attached for a couple of hours. I suspect there is something fishy with the controller card in the external casing, or PSU since the drive was working when attached to a SATA port directly. –  Qben Sep 3 '13 at 5:46

1 Answer 1

The first step is to diagnose if the disk itself is fine. Accessing it via eSATA was a good first step, but a broken controller board in the external casing might still interfere. So remove the drive from the case and connect it directly to the SATA bus in your computer.

If that works then either the external casing or its PSU is bad.

If that does not work then you have a problem with the disk.
The most likely problem is the disks lubricant. Some models use oils which solidify over time and regular usage (moving the parts) helps a buildup of solid tar-like particles. If that is the case (and I want to stress that this is just one option) then this should show up in the SMART values of the disk.

The normal solution is either to:

  1. Ditch the disk (no important data)
  2. Or send it to a recovery service (expensive!)
  3. or attempt to fix it on your own by twisting the disk at power up time. (Rotating the disk casing in the plane in which it spins).
    Needless to say, do not attempt this unless you make sure that it is a spin-up problem. Make sure the cables are long enough, etc etc.
share|improve this answer
    
Interesting points, I will continue the investigation from your suggestions. I was about to test connecting the drive itself to the SATA port of my computer to verify the disk itself. –  Qben Sep 2 '13 at 14:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.