Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Today i have installed the xdebug packets. After installing them my phpmyadmin and different other softwares aren't working anymore. PhpMyAdmin gives this output: json extension is missing. First there was an other error displayed: mbstring extension is missing. I could fix this error by installing the zend-php-extensions. Im using Ubuntu 12.04 and the zend server for php5.2.

How can i install this extension?

share|improve this question
up vote 3 down vote accepted

Json is installed with PHP5.2

go to /etc/php5/mods-available/json.ini and uncomment priority=20 (remove the semicolon)

restart apache2 and it will be ok

share|improve this answer

I had this error today. After doing some search it turned out it was caused by my upgrade from Ubuntu 13.04 to 13.10.

The fix was simple: run "sudo apt-get install php5-json".

Then I restarted apache: "sudo service apache2 restart"

share|improve this answer
    
Yep that fixed it here. – PedroMorgan Nov 8 '13 at 21:04
    
Yeah - this is the one for me too. – Jason Hooks Nov 28 '13 at 0:14

Well, for me it worked after loading the installed modules json and mcrypt.

$ sudo php5enmod json && sudo php5enmod mcrypt
$ sudo service apache2 restart

Go to http://yourserver/phpmyadmin and take a look to check if it works.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .