Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

Recently, while I was installing windows 7, I tried to re-partition my 750 gb hdd. There were following partitions inside my HDD:

  1. Swap
  2. Ubuntu
  3. Backtrack
  4. System reserved for Windows 7
  5. Windows 7

I tried to remove old windows 7's reserved partition (which is 100 mb). And my laptop suddenly stuck and there was no way to continue installation process but restart.

When I restarted my laptop, BIOS was detecting HDD as device but nothing else. Just black screen.

I rejected hdd from my laptop and tested on another pc.

I tried to fix this problem using bunch of software such as: Gparted (which stuck during loading process, and alerted message "... kernel panic ...") , Mini XP (doesn't see any hdd device), Windows 7 (alse didn't see any hdd device).

What do you suggest? Thx in advance for your time.

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007, Tog, Mokubai, Dave M, Scott Sep 9 '13 at 23:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Sounds like you may want to run a hard drive test. –  Moses Sep 2 '13 at 16:40

1 Answer 1

Try using WinDFT and run an Extended Test on your drive. If that passes, erase the disk and then try to repartition

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.