Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don't know if any of you have experience with GroovyArcade, but hopefully someone's heard of it. It's an all-inclusive Linux live CD designed for emulating old game systems and arcades, based on Arch and running a version of MAME. I recently installed GroovyArcade to the hard drive of an old Intel Mac Mini I have, and I'm having trouble installing my own ROMs. The ones that came built-in work, it just doesn't recognize the ones I add.

I'm able to successfully FTP into the machine, upload the ROM to the /home/roms/roms folder and the snapshot to the /home/roms/snaps folder, and give each the correct permissions (777) and group (arcade) to match the other ROMs and snapshots in those folders. But when I then load up AdvmenuPLUS it fails to recognize the ROM and thus the game cannot be played. I've tried adding the /home/roms/roms folder as a ROM path, rebooting, and repeating the process with multiple different ROMs (galagamf, galagamw, and galagao), but nothing seems to work. Googling, searching and posting in the GroovyMAME forums, and combing through the file system have turned up nothing useful so far. As I installed GroovyArcade natively on the hard drive instead of just on a USB flash drive, the USB installation guide (from the GroovyArcade Google Code site) suggestion to add the ROM path wasn't very useful either as it's installed directly to the drive.

The interesting part is that when I adjust the filter to show uninstalled games and locate the greyed out Galaga selection (the game I'm trying to add), the selection successfully displays the snapshot I uploaded. So clearly the snapshot is being recognized correctly, but I'm still not sure why the ROMs aren't.

I'm sure I'm missing something simple, but I have no idea what. Any help would be greatly appreciated.

share|improve this question
    
Have you tried to post on that forum? Your link just redirects me to the forum, not to a single post. –  Doktoro Reichard Sep 2 '13 at 18:58
    
I did. Here. It was very unuseful, which was surprising considering how active the forum is. I didn't have enough reputation to include more than two links in my post, and for whatever reason decided the other two would be more useful. –  thisisme Sep 3 '13 at 3:15
    
Well, it has only passed one day, you shouldn't expect instant problem solving. The poster makes a good point: have you compressed your ROM's? Most programs fail whenever the zip is strangely compressed. Try to re-save those ROM's using no compression whatsoever. –  Doktoro Reichard Sep 3 '13 at 8:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.