Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Adobe Reader XI on Windows XP. I use PDFCreator to print documents to .pdf files.

I want to have the window maximized whenever I open a .pdf file.

I tried the method in: http://blogmines.com/blog/2010/03/08/how-to-automatically-open-a-application-in-a-maximized-window/ but it didn't work. Maybe because I am modifying the shortcut but double clicking on the .pdf file may bypass the shortcut. The AcroRd32.exe application itself doesn't have the maximize window option.

I tried changing the Adobe Reader preferences: Restore last view settings when reopening documents. or Page Display: Default Layout and Zoom.

I also tried changing the settings in PDFCreator: Page layout.

None of the options explicitly control the maximize window option.

When I open a .pdf file with the default Adobe Reader application, whether the window opens maximized or normal (not maximized) is like a random coin toss. Sometimes it is maximized, sometimes not maximized. It is not consistent.

I wonder if anybody has a simple solution. If not, I think I would have to make do with this strange unpredictability.

I was reading this link: http://forums.adobe.com/message/3675347

A second version would be to create a Program Item that does "start /max acrobat.exe" or "start /max acrord32.exe" as appropriate, possibly with path information.

Has anybody done this and could someone explain in detail the steps?

share|improve this question
    
A "safe" workaround is to use the key sequence [Alt, Space, X] to maximize the window. This saves the effort of aiming the mouse at the blue bar. –  tech Sep 4 '13 at 1:14

1 Answer 1

First of, this solution took some reverse engineering and random spelunking through the very vague resources Adobe gives. Feel free to check the revision log for the process that lead me to the solution; as it is quite big for what it's worth I've let it out of the answer.

Now, for the actual solution. Adobe Reader 10.0 in Windows stores it's window settings in these two places in the registry:

HKCU\Software\Adobe\Adobe Reader\10.0\SDI\bMaximizeNextDocument
HKCU\Software\Adobe\Adobe Reader\10.0\SDI\bNullDocMaximized

The two indicate Adobe to start maximized when opening a file and when opening the program itself (e.g. blank file). However, by setting manually those two values alone to their proper values only works once, because Adobe wants to revert back to it's predefined setting (which is to occupy all space on screen in a single regular window)

Alert: the following involves messing with the Windows Registry. Make a backup beforehand and thread lightly. You may end up messing up your system if you don't take proper precautions. And so on and so on. You have been warned.

My solution is to prevent access to Adobe Reader to those values. First of, you need to set those values to their proper values before blocking access to the branch. Access regedit and navigate to HKCU\Software\Adobe\Adobe Reader\10.0\SDI\ Here are the before and after values for the relevant keys:

bMaximizeNextDocument (0) -> (1)
bNullDocMaximized     (0) -> (1)

Right-click the /SDI/ branch and select Permissions. From there press on Advanced.

On the Permissions tab, select your username and afterwards press the Edit button. Check the following checkboxes on the Deny side:

  • Define value
  • Create subkey
  • Delete
  • Delete DAC
  • Owner write

(I apologize beforehand if any of the terms don't match exactly, as I'm not in an English version of Windows and as such the translation might be off)

I might be somewhat conservative in the choices but this works. Probably the only key needed to deny would be "Define value". After all this is done press OK. A warning message might appear, confirm it, and exit regedit. Assuming everything is done right, Adobe Reader can no longer return to it's defaults regarding window placement.

Therefore, Adobe Reader will always open maximized, regardless of whatever window you happened to put in any session.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.