Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Currently I have a flash drive plugged into my computer, however no autoplay action is fired and the drive does not show up in My Computer. However, in Disk Management I see the drive and can use it by manually typing in the mount letter into explorer (E). Any idea as to why this is happening?

I have two HDDs mounted as C & D.

share|improve this question
up vote 0 down vote accepted

Solved this on my own, apparently my past self hid the E drive from my computer using the "NoDrives" registry key. Deleted the key, problem solved. For more information on the NoDrives key, see here.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .