Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Problem:

After an ASUS BIOS update to improve stability for 45 nm quad-core processors.

On the next reboot, got the Windows Loading screen, and then a blue screen. Rebooted again, another blue screen.

I have 2 partitions C: and D: I need a way to get the data off my D: partition so I can wipe the entire system out and start over, but I can't see the data on D:.

I know it's there; I can see it listed in the ASUS EzFlash 2 utility I used to do the BIOS update.

What I've tried:

I tried reverting to the previous BIOS, it still blue screens.

So I popped in my shiny new Windows 7 DVD and did a "Repair my computer."

It found an issue with my boot configuration so I told it to fix it.

Rebooted, blue screen.

Then I remembered that I had previously had my system configured with two 640GB hard drives sharing a mirrored C: (Master) and D: (Data) partitions, and realized that the BIOS update reverted the HD configuration to IDE, so I flipped it back to RAID. Reboot, No OS installed.

Popped the Win7 DVD back it, did a "Repair my Computer", it found more problems with the boot configuration so I told it to fix it, it told me that it couldn't.

I tried reformatting the C: but now it's just a "Primary" partition and not a System one.

Now I'm sitting with no bootable drives, a ton of data on my D: partition that I can't get to, and I'm stumped.

Next I tried a Linux Live CD (Kubuntu 9.04).

I thought this would be a life saver, but I can't mount the existing C: or D: Windows partitions.

Fdisk is telling me that they are FAT16 partitions, not NTFS. I'm guessing it's because of the RAID configuration.

share|improve this question
up vote 1 down vote accepted

Alright, I figured it out.

I installed the 'dmraid' package and activated the RAID partitions. After some trial and error, I was able to mount my data partition and copy the files off onto the external.

What a fiasco... and a learning experience.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .