Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to figure out why Ubuntu and Linux Mint only run in Software Rendering Mode on Virtualbox. My motherboard supports hardware virtualization and it is turned on, and I have installed the Guest Additions succesfully. Both OSs are extremely sluggish.

I am running an MSI GS70 laptop with a Core i7 processor and a GTX 765M gpu with optimus.

I have turned on 3d acceleration, given the maximum GPU allowance, updated my GPU driver to 326.80, installed guest additions. All of these things helped slightly but have not solved the problem, Linux Mint is still showing that I am running in software rendering mode only.

Anything I can try, or questions I should be asking?

share|improve this question

To fix:
shut down the Linux Mint VM.
Edit the VM settings in VirtualBox.
Click "Display -> Enable 3D Acceleration"

share|improve this answer
2  
As stated in my post, I have been using 3D acceleration. – Ty Underwood Sep 18 '13 at 18:57
1  
This worked for me, thanks! – Richard-dW Jul 11 '14 at 7:24
    
Doesn't work for me in VMWare when I enable the equivalent setting. – Sridhar-Sarnobat Aug 24 '14 at 19:09
    
Thanks, Worked for me too. :) – Udhay Apr 17 '15 at 15:25

This seems to be an issue with VirtualBox Guest Additions 4.3.8-4.3.12. It seems that 4.3.13 fixes the issue. , though I cannot find an available pre-RC ISO any longer.

Sources:

Update: I was able to bypass the issue using 4.3.10 that is packaged with Linux Mint 17 by avoiding the untested updates which contained several updates to mesa and opengl. I had no issues by sticking to the security updates until 4.3.13 is officially released.

Imgur

share|improve this answer
    
They are updating the links in the VBox Ticket. The latest link is: virtualbox.org/download/testcase/… – Scolytus Jun 26 '14 at 15:27

I faced this problem recently, with host Virtualbox 5.0.22 (Win 10 64bit) and guest Mint 18 Cinnamon version (Sarah).

When I start the Mint 18 guest VM, it takes a longer time to start, and says that cinnamon is currently running in software rendering mode.

To fix,

  • In the Virtualbox display settings, enable 3D acceleration and give it enough display memory. Guest OSes which use 3D effects generally require more than 8MB (required for 1920 x 1080 32 bit color display). I set my VM display mem to 128MB - Though I believe display memory size does not matter much in case of software rendering mode problem. How do I calculate video RAM requirements?

  • If you dont have a shared folder on host with guest VM - Create a shared folder on host. In Virtualbox Manager, rightclick VM > Settings > Shared Folders > Add button (on right side). Make it auto-mount, and also permanent if you like.

  • You may need to restart the guest linux VM.
  • Copy the VirtualBox guest additions ISO file to the shared folder on Host. Make sure the ISO version matches the VirtualBox version.
  • sudo adduser UserName vboxsf - Run this on guest linux. Replace UserName with your user name.
  • You may need to restart the guest OS.
  • Copy the guest addition ISO to your guest OS disk from shared folder (in mint, the shared folder is /media/sf_FolderName)
  • Install the guest additions. Right-click on the iso file > open with > disk image mounter. It will show dialog saying "This medium contains software intended to be automatically started. Would you like to run it?". Accept and continue. - OR - Follow instructions here, if you are using another linux version - https://www.virtualbox.org/manual/ch04.html
  • Restart the guest linux.

Also try following if above does not work-

With Windows 10, hardware acceleration is always on if the graphics driver supports it. Update host display drivers.

Update and Upgrade the linux guest too.

share|improve this answer

It's an old question,but today I was faced with the same problem with Linux Mint 18 (Sarah) Cinnemon + Oracle Virtualbox Version: 5.0.10 r104061. (Host OS is Windows 10.)
I used 3D acceleration as you, so this was not the problem.
I am new with Linux and Vbox, so maybe it is not the whole thing, but after I have run the Guest Additions, Mint could run in normal mode (not in Software Rendering Mode).
Steps:

  1. Start Linux Mint machine in Vbox
  2. Choose: Devices / Insert Guest Additions CD image... (see picture in the link below)
  3. Run it
  4. Reboot Linux Mint machine
    This solved my problem. I hope, it will solve others' problems, too.
    See the image here.
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .