Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When logging into a remote Ubuntu session using ssh, my command line history, which I'd usually access on my local terminal with the cursor keys is replaced with ^]]A ^]]B characters etc.

How can I enable the command line history on this remote session?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

OK, it turns out my login was set to use /bin/sh. I changed my login shell to bash by changing /etc/passwd and my problems were solved

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.