Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a late 2010 13" Macbook Air and I have problems turning Wi-Fi on when I wake the computer up.

I keep my laptop connected to power, an external screen and a USB ethernet adapter at home and thus turn Wi-Fi off. When I put the computer to sleep in this state, disconnect the cabels and later wake it up I have problems turning Wi-Fi on again.

As an example, one morning when I woke the computer up at school after being asleep all night I could not enable Wi-Fi. When I pressed "Turn Wi-Fi On" in the menu bar it didn't react at all, the symbol still indicate it is turned off (an outlined fan symbol without any of the "radio waves" in it) and no Wi-Fi networks are visible in the drop down menu.

I ran the following commands to get some debug output

$ /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport en0 debug +AllDriver +AllVendor
$ /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport en0 logger

then I ran the following commands in another terminal

$ networksetup -setairportpower en0 off
$ networksetup -setairportpower en0 on

and got the folowing from the above airport en0 logger command

Wed Sep  4 08:40:05: <kernel> en0: setting diversity to: -1
Wed Sep  4 08:40:05: <kernel> en0: Error configuring antenna diversity (index = -1).
Wed Sep  4 08:40:05: <kernel> en0: setting tx antenna: -1
Wed Sep  4 08:40:05: <kernel> IO80211ScanManager::startScan: Broadcast scan request received from pid 33764 ().
Wed Sep  4 08:40:05: <kernel> IO80211ScanManager::getScanResult: All scan results returned for pid 33764.
Wed Sep  4 08:40:06: <kernel> IO80211ScanManager::startScanMultiple: Scan request received from pid 33922 (16 SSIDs, 0 BSSIDs).
Wed Sep  4 08:40:06: <kernel> IO80211ScanManager::startScanMultiple: Initiating scan.
Wed Sep  4 08:40:06: <kernel> IO80211ScanManager::startScan: Broadcast scan request received from pid 33764 ().
Wed Sep  4 08:40:06: <kernel> IO80211ScanManager::getScanResult: All scan results returned for pid 33764.
Wed Sep  4 08:40:06: <kernel> IO80211ScanManager::startScan: Broadcast scan request received from pid 33764 ().
Wed Sep  4 08:40:06: <kernel> IO80211ScanManager::getScanResult: All scan results returned for pid 33764.
Wed Sep  4 08:40:06: <kernel> IO80211ScanManager::startScan: Broadcast scan request received from pid 33764 ().
Wed Sep  4 08:40:06: <kernel> IO80211ScanManager::getScanResult: All scan results returned for pid 33764.
Wed Sep  4 08:40:06: <kernel> IO80211ScanManager::getScanResult: All scan results returned for pid 33922.
Wed Sep  4 08:40:06: <kernel> IO80211ScanManager::startScanMultiple: Scan request received from pid 33922 (16 SSIDs, 0 BSSIDs).
Wed Sep  4 08:40:06: <kernel> IO80211ScanManager::startScanMultiple: Initiating scan.
Wed Sep  4 08:40:08: <kernel> IO80211ScanManager::getScanResult: All scan results returned for pid 33922.
Wed Sep  4 08:40:08: <kernel> IO80211ScanManager::startScanMultiple: Scan request received from pid 33922 (2 SSIDs, 0 BSSIDs).
Wed Sep  4 08:40:08: <kernel> IO80211ScanManager::startScanMultiple: Initiating scan.
Wed Sep  4 08:40:09: <kernel> IO80211ScanManager::getScanResult: All scan results returned for pid 33922.
Wed Sep  4 08:40:09: <kernel> IO80211ScanManager::startScanMultiple: Scan request received from pid 33922 (2 SSIDs, 0 BSSIDs).
Wed Sep  4 08:40:09: <kernel> IO80211ScanManager::startScanMultiple: Initiating scan.
Wed Sep  4 08:40:11: <kernel> IO80211ScanManager::getScanResult: All scan results returned for pid 33922.

Here something interesting happens. After running the above networksetup command, the Wi-Fi icon in the menu bar starts the "searching for networks" animation and indicates that Wi-Fi is indeed turned on. However, it does not connect to any network (there is one in range that it should auto connect to) and I see no networks in the list.

After I reboot my computer it is always back to normal with no Wi-Fi problems what so ever but I wish I didn't have to reboot every time this happens.

Any ideas at all?

Update

I've been asked if this has been solved. As it is now, however, I cannot reliably answer that question as I haven't been using that computer much lately, at least not for this use case. I do however seem to remember that it worked out better after I updated to Mavericks, but I am not sure. Sorry folks.

share|improve this question
    
I have a similar, but different issue. I have users whose MBP do not connect to WiFi after coming out of sleep. Perhaps the answer here will apply... –  Keltari Feb 6 at 15:41

2 Answers 2

I had a similar problem with a 2011 MacBook Air, but it went away after I turned off Bluetooth from System Preferences, so it might have been caused by something like Bluetooth interference. Others have changed the Wi-Fi frequency channel from the preferences of their router.

Related questions:

share|improve this answer
    
The problem is not that I have trouble connecting to Wi-Fi networks, it is that my Wi-Fi is disabled and cannot be enabled since pressing "Turn Wi-Fi On" does absolutely nothing. Hence, this does not seem to be related to any combination of routers since it happens before I connect. On top of all this I can think of several different geographical places with different routers where this has happened to me. Since I am not able to enable my Wi-Fi using either the GUI or the command line, it seems it is not related to any of those questions you linked. –  Sebastian Ärleryd Sep 4 '13 at 16:31
    
I tried disabling Bluetooth after I got the problem last time, but it didn't help. I have not tried keeping Bluetooth disabled to see if the problem no longer occurs since I use a wireless keyboard. –  Sebastian Ärleryd Sep 4 '13 at 16:32
    
Yeah, I thought it's probably a different issue. I was able to connect to a Wi-Fi network after turning Wi-Fi off and on from the menu bar or with networksetup -setairportpower en0 off; networksetup -setairportpower en0 on. –  ؘؘؘؘ Sep 4 '13 at 17:20
    
Hum, OK. That only seem to poke at my dead Wi-Fi's corpse and make it twitch a bit since the icon actually reacts and starts the connection animation but fails to connect and shows no networks in the list. –  Sebastian Ärleryd Sep 4 '13 at 17:35

An dutch website (appletips.nl) found the solution that works (also with an terminal command), you can find the article with translation here: http://bit.ly/1z1ii5z

Original article: http://www.appletips.nl/macbook-wi-fi-problemen-oplossen-na-het-ontwaken-uit-sluimerstand/

share|improve this answer
2  
Could you please give a bit more information about this solution, not just a link. –  Chenmunka Jun 30 '14 at 7:46
    
This does not seem to be the same problem that I had. The problem described on the web page you linked to can be solved by turning WiFi off and then on again (as it says on the web page). My problem was that nothing but rebooting works. –  Sebastian Ärleryd Jun 30 '14 at 9:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.