Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install .NET Framework 4.5 to the remote Win2008R2 Server via PowerShell session in such way (user is in the server Administrators group):

$session = New-PSSession -ComputerName $server -Credential Get-Credential
Invoke-Command -Session $session -ScriptBlock {Start-Process -FilePath "C:\temp\dotnetfx45_full_x86_x64.exe" -ArgumentList "/q /norestart" -Wait -PassThru}

And then I get this error:

Executable: C:\temp\dotnetfx45_full_x86_x64.exe v4.5.50709.17929

--- logging level: standard ---

Successfully bound to the ClusApi.dll

Error 0x80070424: Failed to open the current cluster

Cluster drive map: ''

Considering drive: 'C:\'...

Drive 'C:\' has been selected as the largest fixed drive

Directory 'C:\aa113be049433424d2d3ca\' has been selected for file extraction

Extracting files to: C:\aa113be049433424d2d3ca\

Error 0x80004005: Failed to extract all files out of box container #0.

Error 0x80004005: Failed to extract

Exiting with result code: 0x80004005

=== Logging stopped: 2013/09/04 16:29:51 ===


If I run command locally at the server - all works fine.

Start-Process -FilePath "C:\temp\dotnetfx45_full_x86_x64.exe" `
-ArgumentList "/q /norestart" -Wait
share|improve this question
add comment

2 Answers

I was having the exact same issue and it felt familiar so I dug through my memory and remembered how I fixed it last time. The issue is caused by the limit on the amount of memory available to your PS remote session. This article shows you how to query it. If you up it to 1GB, you should be able to install .NET 4.5 without issue.

share|improve this answer
    
Already have MaxMemoryPerShellMB = 1024 –  user251297 Dec 3 '13 at 15:15
add comment

Try disabling any firewalls and AV. 0x80004005 seems common to those.

share|improve this answer
    
Do not have any antivirus installed on the server. I have turned off Windows Firewall. Did not help. Still the same error. –  user251297 Sep 5 '13 at 6:52
    
$proc = (start -FilePath "C:\temp\dotnetfx45_full_x86_x64.exe" -ArgumentList "/q /norestart" -Wait -PassThru) $proc.ExitCode returns 16389 –  user251297 Sep 5 '13 at 6:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.